Mac Newb, Flirting with the switch

Discussion in 'Mac Basics and Help' started by Razorhog, Sep 16, 2006.

  1. Razorhog macrumors 65816

    Razorhog

    Joined:
    Sep 16, 2006
    Location:
    Arkansas
    #1
    Hello all, I am a Mac newbie. I am thinking of switching to Mac, and borrowed an iBook G4 from work to play with. First thing I wanted to do is get it connected to my wireless network, but when I try it says "there was an error joining the selected airport network". If I disable WEP security, it connects fine. Anyone have suggestions? Thanks!
     
  2. pianoman macrumors 68000

    pianoman

    Joined:
    May 31, 2006
    #2
    i'm not positive, but perhaps you have to have some type of digital certificate.

    anyone else have an idea?
     
  3. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #3
    Are you entering a password to connect to the network? I assume you must be. If so, you should know that there isn't a standard method of handling text passwords in WEP -- Windows and OSX encode them for transmission using different algorithms. So, what you need to do is determine and enter the hex equivalent password for your wireless router (AKA, the WEP key). If you were using an AirPort base station I could tell you how this is done... your router software should have a way of reporting this string.
     
  4. JDN macrumors 6502a

    Joined:
    Sep 7, 2006
    Location:
    Lund Sweden {London England}
    #4
    I can only go on what i have to do on my MBP, but if you click on the wirless signal indicator in the task bar and then select other network, manually type in the SSID and then choose to enter a WEP key. If the signal indicator isnt there, then go to the system preferences click network, and go from there.

    I seem to remember when i fist got my MBP and hadnt entered the WEP key it gave me funny messages too.
     
  5. GimmeSlack12 macrumors 603

    GimmeSlack12

    Joined:
    Apr 29, 2005
    Location:
    San Francisco
    #5
    DON'T GET A MAC!!!! NOOOOO....

    Just kidding. Um if WEP turned off makes it connect fine then doesn't that mean that WEP isn't needed (or turned on at all).
    Getting a Mac is just another way of doing everything you did on your PC, but with generally less possibility for problems and usually a little more elegant interface. It is true when people say "It just works".
     
  6. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #6
    Using WEP has little/nothing to do with the security of your network and everything to do with prohibiting poaching on your broadband connection.

    Open wireless routers are popping up all over the place these days, especially since the phone companies began offering inexpensive DSL and bundling wifi routers with the service. Wireless, and unprotected wireless at that, seems to be the default setting on these routers. Probably few DSL customers actually use the wifi and even fewer realize that they're providing it free of charge to their neighbors.
     
  7. beige matchbox macrumors 6502a

    beige matchbox

    Joined:
    Mar 16, 2005
    Location:
    Oxfordshire, UK
    #7
    I have to stick 0x infront of the WEP key on my macs, never know ;)
     
  8. CyberB0b macrumors regular

    CyberB0b

    Joined:
    Apr 19, 2004
    #8
    Razorhog, in your router settings when you turn on WEP look for hex characters. There should be up to four unique strings of characters 0-9,A-F in there. The hex key is either 10 or 26 characters long. Now when you go to join the network on the iBook choose "WEP 40/128-bit hex" in the drop down and enter the characters.
     
  9. Razorhog thread starter macrumors 65816

    Razorhog

    Joined:
    Sep 16, 2006
    Location:
    Arkansas
    #9
    Thanks for all of the replies, but I'm still not connecting :( I'll try to attach a screen of what my router's setting page looks like.
     

    Attached Files:

  10. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #10
    You won't be able to connect using WEP until you locate your WEP key. Apparently you have a default key printed on the bottom of your router. Try that -- and set the WEP encryption on default.
     
  11. Razorhog thread starter macrumors 65816

    Razorhog

    Joined:
    Sep 16, 2006
    Location:
    Arkansas
    #11
    So far I have tried:
    Updating Airport software to latest version
    numerous different WEP keys (long, short, all numbers, etc)
    Selecting "other" and manually putting in the SSID
    converting ASCII to Hex

    I'll try IJ Reilly's Idea of using the default key
     
  12. Razorhog thread starter macrumors 65816

    Razorhog

    Joined:
    Sep 16, 2006
    Location:
    Arkansas
    #12
    Still no go...
    By the way, this is OS X 10.3.9

    And a side question, what is that noise it makes when I wake it up?
     
  13. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #13
    The Mac makes a noise when you wake it up?

    Only one WEP key will work, the hex equivalent of the plain text password you set. It might be time to ask tech support of the router manufacturer how you discover this string.
     
  14. Razorhog thread starter macrumors 65816

    Razorhog

    Joined:
    Sep 16, 2006
    Location:
    Arkansas
    #14
    Well the default key is a 10 digit number from the bottom of the router. I've tried converting it, and other plain text keys to hex and nothing is working. :mad:
     
  15. Razorhog thread starter macrumors 65816

    Razorhog

    Joined:
    Sep 16, 2006
    Location:
    Arkansas
    #15
    Oh and yes it makes a russling noise when I wake it up. Is it supposed to sound like someone getting out from under the covers? :rolleyes:
     
  16. Razorhog thread starter macrumors 65816

    Razorhog

    Joined:
    Sep 16, 2006
    Location:
    Arkansas
    #16
    Apparently this is not an uncommon problem, but I can't seem to find a definitive fix. I guess I'll just remove the wep key when I want to surf with the iBook wirelessly.
     
  17. Razorhog thread starter macrumors 65816

    Razorhog

    Joined:
    Sep 16, 2006
    Location:
    Arkansas
    #17
    This is strange - I disabled the wep key, connected to the router with the ibook (wired) and set the key. It instantly connected...I didn't even put the password in... which made me wonder. So I log back into the router with my wired windows xp machine, and it shows that no wep key is set. Log in with the iBook and it shows that it is set. :confused:
     
  18. applemacdude macrumors 68040

    applemacdude

    Joined:
    Mar 26, 2001
    Location:
    Over The Rainbow
    #18
    cant u just type the wep number on ur 2wire router as the password.. thas what i do
     

Share This Page