Mac OS X, Apache, SMF

Discussion in 'Web Design and Development' started by geodome, Oct 22, 2006.

  1. geodome macrumors member

    geodome

    Joined:
    Jun 22, 2006
    Location:
    London, UK
    #1
    I use Mac OS X Tiger on my laptop.

    I recently enabled the build-in Apache server on my Mac, thinking the URL http:/127.0.0.1 will give me access to my username/Sites folder. Instead, it displayed Library/WebServer/Documents.

    How do I change it to username/Sites? I tried to change it by runnin 'httpd DocumentRoot Username/Sites' but I was given an error message. Someting fopen cannot work.

    Frustrated on the above problem, I installed Simple Machine Forum 1.1 (SMF) in the Library/WebServer/Documents folder and ignored the problem that it isn't in my desired folder. However, I realise I cannot configure SMF to ftp with my laptop, despite entering the correct password and username. Instead, SMF reports "Welcome to Darwin".

    Please help. I need the FTP to work, so that I can install mods.
     
  2. jsw Moderator emeritus

    jsw

    Joined:
    Mar 16, 2004
    Location:
    Andover, MA
    #2
    To get to your user site, go to http://127.0.0.1/~username.
     
  3. miniConvert macrumors 68040

    miniConvert

    Joined:
    Mar 4, 2006
    Location:
    Kent, UK - the 'Garden of England'.
    #3
    I adore having a built in webserver. Ok, some of the built in *nix elements of OS X are a little tough to reconfigure, especially with the limited GUIs, but wow is it nice just having them there ready to run!
     
  4. ddekker macrumors regular

    Joined:
    Sep 23, 2006
    Location:
    Michigan
    #4
    on my linux servers I run Webmin... I wonder if it can be loaded on OS X?... I run OSX server on our OS X server machine, I do most things at a command line though, I find the GUI's do some strange things..

    DD
     
  5. Grover macrumors member

    Joined:
    May 14, 2004
    #5
    You can try editing httpd.conf which is found in /etc/httpd. Look for this:

    #
    # DocumentRoot: The directory out of which you will serve your
    # documents. By default, all requests are taken from this directory, but
    # symbolic links and aliases may be used to point to other locations.
    #
    DocumentRoot "/Library/WebServer/Documents"

    and change the path to your home Sites directory. Restart Apache. You may also have to change the permissions on your Sites directory so that Apache has access to it.

    If instead you feel like deleting things, you could also try removing or renaming the /Library/WebServer/Documents folder and replacing it with a symlink to your Sites directory. This may also require a change to the permissions on your Sites directory.
     
  6. ThunderLounge macrumors 6502

    ThunderLounge

    Joined:
    Sep 20, 2006
    #6
    You don't have to have ftp available. It only uses it if it need to chmod files to make a back-up and then make the changes.

    Since this is localhost, there is a much easier option.

    Assuming you haven't enabled access from the web to your localhost, simply chmod the "Sources" and "Packages" directories to 777, and the same for the files inside it. (chmod -R 777 Sources)


    Then no need to worry about needing the "ftp" access.



    Edit...

    You're a "Mac" guy geo?
    Wow. Small world, huh?

    Tell Mitch hi.

    I can confirm that 80% of your portal of choice was written on a Mac. ;)
     

Share This Page