Mac OS X v10.5.8 really required?

Discussion in 'iPod touch' started by JanvB0, Sep 1, 2010.

  1. macrumors newbie

    Aug 11, 2010
    Is Mac OS X v10.5.8 really required for the new iPod Touch and why would that be? Even Windows XP is supported :S I'm still running Tiger, with which I'm happy and students don't have a lot of cash to spare ;)
    Thanks in advance!
  2. celticpride678

    Feb 15, 2009
    Boston, MA
    Probably because it has something to do with iTunes 10 support.

Share This Page