mac osx 10.5.8 and adobe CS5

Discussion in 'OS X' started by trailofdan, Feb 28, 2011.

  1. macrumors newbie

    Feb 6, 2009
    Is anyone currently using adobe CS5 software on there mac that's running leopard 10.5.8 (not snow leopard). I just want to know if its running okay as on the adobe software operating system requirements it says 10.5.7 or 10.6 (nothing about 10.5.8).

    I have got snow leopard but don't like how they've messed with expose (uninstalled it and reinstalled leopard) so I want to use CS5 on 10.5.8

    Sorry if this thread is in the wrong forum section.

  2. macrumors 6502


    Jan 25, 2010
    10.5.7 is minimum for running Adobe CS5, anything higher will run it just fine.
  3. Moderator emeritus

    Jul 4, 2004

    Yes. That's exactly my setup and it works fine.

    Offhand, one thing you have to watch out for is running Photoshop in 32-bit mode if you want to run a scanner using a TWAIN plugin, like I do. More info here:

    I'll probably skip Snow Leopard and go to Lion when it's at 10.7.3 or so.
  4. thread starter macrumors newbie

    Feb 6, 2009

Share This Page