Mac Pro and FCE

Discussion in 'Digital Video' started by NTJetboater, Dec 1, 2006.

  1. NTJetboater macrumors member

    Joined:
    Oct 19, 2006
    Location:
    Yellowknife
    #1
    Which version will work with the new MP. I was looking on ebay and there are a few dozen for sale. The one guy emailed me and mentioned that 3.0 might not work with the MP.
    Do I need the newest(most expensive of course) version.

    suggestions???
     
  2. -DH macrumors 65816

    Joined:
    Nov 28, 2006
    Location:
    Nashville Tennessee
    #2
    You'll need the universal binary version: 3.5 The universal version will work on both PPC and Intel Macs. It's available from Apple at $299.00 for the full retail version or as a $99.00 upgrade.

    -DH
     

Share This Page