Mac Pro hard drive spins down even though I tell it not to

Discussion in 'Mac Pro' started by quasar720, Nov 18, 2006.

  1. quasar720 macrumors member


    Aug 11, 2004
    Berkley, MI
    I'm having a strange problem where the main HDD in my mac pro (standard 250GB running OS X in bay 1) will spin down after 5-6 minutes of inactivity.

    It does this despite the fact that I have the "Put the hard disk(s) to sleep when possible" option unchecked in the Energy Saver system preferences panel.

    It's really quite irritating as I will be working in front of my computer and then need to access something but will be forced to wait for the drive to spin up before I regain control.

    If I am in front of it for an extended period of time I will even hear it spin down like this and then be quiet for a few minutes only to spin up again later without my having done anything.

    I haven't installed any new software recently other than the EFI firmware update from Monday, 11/13. I can't remember if it was doing this prior to that update, but I'm pretty sure it was.

    Is anyone else having this problem or know of a fix? :confused:

    Mac Pro 2.66 Ghz
    2GB Apple RAM
    Bay 1: Mac OS X (standard HDD)
    Bay 2: Windows XP (boot camp install on WD Caviar 250GB SATA II)
    ATI Radeon X1900 (preinstalled by Apple)
  2. mistafreeze macrumors member

    Aug 29, 2006
    i had this problem and unchecked the put hard disks to sleep when possible
    now they only power down after a few hours, which is fine as I never use but one or 2 harddrives at a time
  3. Musubi macrumors member


    Oct 27, 2006
    Hawaii / 東京 日本
    There are times when for some reason, the setting doesn't apply (maybe due to a corrupt preferences file or something else). I noticed this happens often when the first slider (Put the computer to sleep when it is inactive for) is not set to "Never". Checking/unchecking the hard disk sleep box had no effect on the setting stored on disk. I had this problem on my Power Mac but was not able to reproduce it on the Mac Pro.

    Trying running this from the Terminal. It will show the power management settings as stored.

    pmset -g disk

    AC Power:
    womp 1
    hibernatefile /var/vm/sleepimage
    powerbutton 1
    sleep 0
    autorestart 0
    hibernatemode 0
    disksleep 0
    displaysleep 10

    disksleep 0 is the same as having the "Put the hard disk(s) to sleep when possible" option unchecked. If it is already 0, then there is something else overriding the setting causing it to sleep. If it isn't 0 and checking/unchecking the Energy Saver preferences option doesn't change it, you can force it to stick by using pmset -c disksleep 0 (verify by checking with pmset -g disk)
  4. theblotted macrumors regular


    Nov 10, 2006
    Los Angeles
    or you can also type:

    sudo pmset -a spindown 0

  5. quasar720 thread starter macrumors member


    Aug 11, 2004
    Berkley, MI
    Thanks for the replies. I did the pmset -g disk and found that on AC power and UPS my disk was set to spin down after 180 (minutes I assume?). This is weird because it was definitely spinning down sooner than three hours (more like 5-6 minutes).

    I used the sudo command and was able to change this paramater to 0. I'll report back if it doesn't do the trick.

    Thanks again!

Share This Page