Mac Pro keeps freezing with iTunes

Discussion in 'Mac Basics and Help' started by EHUnlucky7x9@ao, Nov 9, 2006.

  1. EHUnlucky7x9@ao macrumors 6502

    Joined:
    Jan 8, 2006
    Location:
    New Jersey
    #1
    Hey guys,

    This has kinda been pissin me off for the past few days. Anytime I have iTunes open for a long time or just playing music, iTunes ends up stalling. I don't know why.


    I have the latest version of iTunes 7.02 or something like that. What's weird is that when everyone was complaining that iTunes 7 was having a problem, i didn't have one. Now that i updated, things are messing up. When i hit the eject button on the ipod in iTunes, it stalls and the spinning rainbow happens. Then after 10 mins i would force quit iTunes, it closes...but the arrow on the dock shows its still open. I would then try to reboot and the mac pro hangs and never gets to rebooting. Everytime this happens, I would have to hold the power button until the machine shuts off. When i turn the MP back on, everything would be working again find so long as I don't touch iTunes, but then my speakers aren't working right. I have no control of the volume with the speaker buttons. I would then have to reboot again to get things working properly.

    Anyone have any suggestions as to what I can do?
     
  2. Swarmlord macrumors 6502a

    Swarmlord

    Joined:
    Sep 18, 2006
    #2
    No other applications cause the same behavior? Only iTunes?

    The only time I have this problem with iTunes is when I'm ripping a scratched or otherwise damaged disk.

    If you have this problem with all applications, then I would suggest that it's a RAM problem.
     
  3. SBik2 macrumors 6502a

    SBik2

    Joined:
    Jul 14, 2006
    Location:
    /private/var/root
    #3

    In spotlight, type in com.apple.iTunes.plist
    then click show all and drag that file(com.apple.iTunes.plist) onto the desktop, then trash it...
    Then restart your MP and tell us your results....
    I had the same problem on my MB till i did that
     
  4. EHUnlucky7x9@ao thread starter macrumors 6502

    Joined:
    Jan 8, 2006
    Location:
    New Jersey
    #4
    No, I have no problem with any other apps. Just iTunes. I will try that out tonight when I get home. I did repair permissions on the disk volume and when it was verifiying it, it said that iTunes had different permissions and the music library so i repaired it and it restarted the App n it was working when i left. I will check it out tonight thoroughly. I'll get back toyou guys with the details. Thanks
     
  5. EHUnlucky7x9@ao thread starter macrumors 6502

    Joined:
    Jan 8, 2006
    Location:
    New Jersey
    #5
    I tried deleting it, but no avail.


    This is what my MP is showing in activity monitor:

    [​IMG]
     

Share This Page