Mac wifi internet slow after ML upgrade, PC still fast

Discussion in 'MacBook Air' started by heyjack70, Jul 29, 2012.

  1. macrumors newbie

    Joined:
    Jul 18, 2012
    #1
    Hi,

    So I bought a new macbook air 2012 about 2.5 weeks ago. Excellent computer by the way, great to use. Then I upgraded to mountain lion 2 days ago, downloaded in about 25-30 minutes. After ML upgrade, my internet connection speed at home and work has been insanely slow. I have 12Mbps service from Comcast at home. With that, my PC laptop on speedtest is getting about 13 Mbps download and 3.5 Mbps upload at home. Two Ipads in the house are also running internet well, but haven't checked specific speeds. Meanwhile my macbook air is has ranged from 0.2 to 1.2 Mbps download, with upload speed around 3.5 Mbps. At work I don't know the specific network details, but it is subjectively much faster than my home internet, I'm getting 1.5 Mbps download there since the upgrade. I don't have pre upgrade speed tests because the internet was running great before mountain lion.

    I've been on the phone with apple tech support and to the Genius bar twice. Several changes to network settings have been tried. Along with that, I've reloaded ML from OS x utilities once, and the Genius bar did a clean install of mountain lion once. Nothing has fixed my macbook air from running slow at home. Interestingly (frustratingly) the network speed at the Apple store ranged from about 21 to 35 Mbps download.

    What the heck is going on? Would the upgrade make my air have trouble interacting with my home internet, but not the wifi at the apple store? I'm going to try and test this on a friend's home wifi tomorrow. If I'm still having problems I think I'm just going to return it. At this point, I would love to go back to lion, but I currently it seems there is no way without having made preparation prior to upgrading to ML, which of course was not done.

    To summarize, mac is slow at home and work, and fast at apple store since ML. PC at home is fast. Any advice?
     
  2. macrumors 6502a

    Joined:
    Oct 21, 2011
    #2
    If Apple are going to remove Ethernet ports from all their Macs they better make damn sure that the WiFi on them is above par. This does not appear to be happening.
     
  3. macrumors 6502

    Joined:
    Sep 24, 2011
    #3
    What router do you use? What security settings do you have enabled? Without informations like this we can't help you.
     
  4. macrumors 6502a

    Joined:
    Apr 12, 2012
    #4
    I'm having a similar issue. I use airport extreme. I have no idea what's going on. Could it be safari?
     
  5. thread starter macrumors newbie

    Joined:
    Jul 18, 2012
    #5
    My router is a Belking n150, security is WPA2. Prior to ML, the air's internet was fine. What was most obvious was loading netflix pages. Prior to ML, 30 seconds max to get started. Now I choose a movie and leave to do something else. 5 minutes later I hear the audio starting.
     
  6. thread starter macrumors newbie

    Joined:
    Jul 18, 2012
    #6
    One more interesting bit of info. When I connect the macbook air through my cell phone with PDAnet, my download speed is about 9 Mbps. I'm connecting to my home internet wifi with my phone, and running a usb cable into my macbook air to get this speed. The macbook air is still sitting at 1 Mpbs or so, max is 1.5 on its own. So connecting through my phone is faster than using the macbook airs built in wifi at this point. There must be some problem with how the macbook air is communicating with the router or ISP; I don't get it.

    I think next step is to try an airport express. If not, I'm really on the fence about returning this thing.
     
  7. macrumors 6502

    dialed1

    Joined:
    Dec 21, 2008
    Location:
    Utah
    #7
    Same here both mine and the wife's computer. macbooks
     
  8. macrumors regular

    Joined:
    May 17, 2012
    #8
    I know this is probably a silly comment, and I apologize in advance for it... But I had a connectivity problem after installing ML on my 2012 Air, where it wouldn't connect after it rebooted. So, I shut the Air down and rebooted again, and it connected. The connection is running very well (not sure of the speed) but the system is very zippy, much moreso than before I installed ML. Anyway, in case you haven't done this (though I suspect you have) try shutting your system down and doing a full reboot. Good luck! And, I'd suggest keeping the system and not returning it over this. The problem has got to be something fixable, and once you do that, you'll be really happy you kept it.
     
  9. macrumors 6502

    Joined:
    Sep 24, 2011
    #9
    If that's the case, the problem is with the router. Maybe ML doesn't have good drivers. Could you test your MBA at home with another router from a friend?
     
  10. kaks, Aug 6, 2012
    Last edited: Aug 6, 2012

    macrumors member

    Joined:
    Feb 26, 2008
    #10
    Same problem

    I just bought an 11'' air i7. I am running mountain lion and my wifi connection speed is really low not to mention sometimes it doesnt even work properly.

    I also have a late 2008 macbook (white) next to it and it connects at full speed on the router, which i am sitting right next it.

    There's 2 routers in my house and i can barely get a signal from the one upstairs on the air. I've even tried the 5ghz band and where my old macbook connects at 270mbps my air gets 28mbps.

    That's insane. I've used other MB Airs before and i never noticed this. I hope it's Mountain Lion.

    I remember checking before upgrading and i had 130mbps which was great at a friends house but never checked at the same house after upgrading.

    Anyway hopefully its ML and it gets fixed as it really bad.

    I have an Airport Express and an Airport Extreme. Same speeds.
     
  11. thread starter macrumors newbie

    Joined:
    Jul 18, 2012
    #11
    Update: I posted this in another thread as well.

    I spent about 2 more hours at the Genius bar, no fix. Still connecting fast via the apple store wifi but slow (extremely slow) at home. I was very certain that the ML upgrade was the cause, so I requested again to have my system reverted to Lion. This wasn't possible, so the Apple Store was awesome and returned my macbook air and sold me a new one that had lion installed. Frustratingly, I took this home and my internet was still slow.

    At this point, my macbook air using two different routers was slow at home, and my work internet was slow, but my PC Dell laptop was fast at home. I was pissed. I ended up buying an airport express, and, low and behold, download speeds of >14Mbps, faster than my PC.

    I'm glad this the problem was solved, but I'm a bit miffed that two perfectly good non-apple routers didn't work. The airport express is a nice little unit, but expensive at $99.
     
  12. macrumors newbie

    Joined:
    Dec 6, 2007
    #12
    anyone else have this issue after upgrading to ML?

    So the solution is to buy a airport express. Sorry for bumping old thread but I am considering doing a re-install but want to avoid it if possible.
     
  13. Guest

    Joined:
    Nov 13, 2012
    Location:
    Netherlands
  14. macrumors newbie

    Joined:
    Dec 6, 2007
    #14
    So I got my new AirPort Express today.

    My speed went from 4mb/s to 70mb/s.
    With BT on it was 2.5mb/s to 30mb/s.

    When I turned on all my other IOS devices (2 iPads, 2 iPhones), 1 ATV and PC desktop I use as PLEX server at the moment while my iMac is waiting to be fixed, it dropped back down to 25mb/s.

    Weird, but still happy with the improvement.
     
  15. macrumors 6502a

    Joined:
    Nov 4, 2012
    #15
    Wait I don't get it. So if you buy a MBA you can't use your normal router you have to buy this Airport Express thing in order to get working wifi?

    This is a joke right?
     
  16. macrumors 6502

    Joined:
    Aug 10, 2012
    Location:
    Sweden
    #16
    No, just another router that plays well with your MBA (the airport express is one of those).
     
  17. macrumors newbie

    Joined:
    Nov 21, 2012
    #17
    This is not a big issue, just re-check your macbook with other device, if the problem still persist, then just contact apple store.
     

Share This Page