Mac/Windows sharing problems

Discussion in 'Mac Accessories' started by wrldwzrd89, Mar 27, 2006.

  1. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #1
    I am having some trouble getting Mac/Windows sharing to work correctly. I used the guide on MacRumors Guides to get everything set up and running, and I was able to connect successfully to my Windows machine. The only problem was that I couldn't use the Internet. I changed some settings and managed to get the Internet working, but now I can't connect to my Windows machine.

    Here's the relevant part of my network setup:

    -Windows machine-
    Wireless access: none
    Ethernet: directly connected to Mac machine
    Internet access: none

    -Mac machine-
    Wireless access: AirPort
    Ethernet: directly connected to Windows machine
    Internet Access: via AirPort

    Relevant Network settings on the Windows machine:

    Configuration method: manual (I gave the machine a static IP address to make connecting to it simpler)

    Relevant network settings on the Mac for AirPort:

    Configuration method: DHCP
    AppleTalk: off

    Relevant network settings on the Mac for Ethernet:

    Configuration method: DHCP (uses a private address since no DHCP server is available on that connection)
    AppleTalk: off

    Network Port Connection Order:

    AirPort, Ethernet, FireWire, Bluetooth

    Note: If I change the order to Ethernet, AirPort, FireWire, Bluetooth, I can connect to my Windows machine but not use the Internet. If I use the order listed I can use the Internet but not connect to my Windows machine.
     
  2. iPhil macrumors 68040

    iPhil

    #2
    Did the windows/Mac sharing work before you changed the settings ??

    Try Mapping the Mac drive thru Windows right click on the My computer then Map this drive .. that should allow you to see the Mac on Windows box :eek:
     
  3. wrldwzrd89 thread starter macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #3
    That's the goofy thing. If I enable Windows Sharing on the Mac and connect to the Mac from the Windows box it works perfectly (I've used the network drive approach in the past with success). Connecting to the Windows box from the Mac fails.
     
  4. iPhil macrumors 68040

    iPhil

    #4
    Try on the Mac to connect to Windows box> Open finder>cmd K > then enter the IP addy of windows box hit connect.. if that doesn't do the trick then hit Browse>then it should be "network" in sidebar of finder>then find the Windows name(Mshome)> then Computer name> connect from there
     
  5. wrldwzrd89 thread starter macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #5
    I tried that. It works with Ethernet first but not with AirPort first. It baffles me since I thought Mac OS X was multihoming and could deal with multiple connections at once.
     
  6. parrothead macrumors 6502a

    parrothead

    Joined:
    Sep 24, 2003
    Location:
    Edmonds, WA
    #6
    Will your PC accept a wireless card? That would make things much simpler in the end. I have two macs and a pc on my airport and I was able to set up a reliable network. Yes it costs money but it could be worth it to skip all the headaches.
     
  7. iPhil macrumors 68040

    iPhil

    #7


    the wireless networking stuff i'm still a n00b @ solving the issues but i'll go my Mac book and try to find an answer to the problem :eek:

    The steps should work if it was only a wired network .. and since I only got a wired network so far thats the area i knowledge i got as of now .. :( :(


    and i'll be back tonight to see if your problem was solved or not and i'll try post my answer from the book :eek:
     
  8. jeremy.king macrumors 603

    jeremy.king

    Joined:
    Jul 23, 2002
    Location:
    Fuquay Varina, NC
    #8
    Why have the wired port on the Mac setup as DHCP? Use a static IP in the same format as your Windows machines static IP, to ensure they are on the same subnet.

    So if the windows machine you setup as 192.168.1.100, setup the Mac's wired ethernet as 192.168.1.101.


    Also, it would be very helpful if you posted the results of the following commands from DOS and Terminal.

    Windows:
    ipconfig /all

    Mac:
    ifconfig -a

    XXXX out any external IP addresses.
     
  9. wrldwzrd89 thread starter macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #9
    As it turns out, I was wrong about the DHCP thing, I changed my Mac's Ethernet card to a static IP address on the same subnet.
    Windows:

    Windows IP Configuration

    Host Name: ASHLEY
    Primary DNS Suffix: (blank)
    Node Type: Unknown
    IP Routing Enabled: No
    WINE Proxy Enabled: No

    Ethernet Adapter Local Area Connection:

    Connection-specific DNS Suffix: (blank)
    Description: Intel(R) PRO/100 VE Network Connection
    Physical Address: 00-11-11-03-36-CF
    Dhcp Enabled: No
    IP Address: 192.168.1.201
    Subnet Mask: 255.255.255.0
    Default Gateway: 192.168.1.200
    DNS Servers: 192.168.1.200

    Mac:

    lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
    inet 127.0.0.1 netmask 0xff000000
    inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
    gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
    stf0: flags=0<> mtu 1280
    en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    inet6 fe80::214:51ff:fe2f:c9f4%en0 prefixlen 64 scopeid 0x4
    inet 192.168.1.202 netmask 0xffffff00 broadcast 192.168.1.255
    ether 00:14:51:2f:c9:f4
    media: autoselect (100baseTX <full-duplex>) status: active
    supported media: none autoselect 10baseT/UTP <half-duplex> 10baseT/UTP <full-duplex> 10baseT/UTP <full-duplex,hw-loopback> 100baseTX <half-duplex> 100baseTX <full-duplex> 100baseTX <full-duplex,hw-loopback> 1000baseT <full-duplex> 1000baseT <full-duplex,hw-loopback> 1000baseT <full-duplex,flow-control> 1000baseT <full-duplex,flow-control,hw-loopback>
    en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    inet6 fe80::214:51ff:fe81:ee01%en1 prefixlen 64 scopeid 0x5
    inet 192.168.1.103 netmask 0xffffff00 broadcast 192.168.1.255
    ether 00:14:51:81:ee:01
    media: autoselect status: active
    supported media: autoselect
    fw0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 4078
    lladdr 00:14:51:ff:fe:2f:c9:f4
    media: autoselect <full-duplex> status: inactive
    supported media: autoselect <full-duplex>
     
  10. wrldwzrd89 thread starter macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #10
    Success!

    After fiddling with the settings some more I got it to work properly. I can now connect to my Windows box from my Mac, connect to my Mac from my Windows box, and use the Internet on my Mac. :D

    As it turns out, I have to use DHCP for assigning Ethernet addresses for both the Mac and the Windows box, otherwise the Mac gets confused because it thinks it should be able to connect to the Internet via Ethernet (when it has a static IP address) but can't, and refuses to try AirPort to connect to the Internet. Once I figured that out, and put Ethernet first in the port order it worked!
     

Share This Page