Mac wont boot past login

Discussion in 'OS X Mountain Lion (10.8)' started by JamesP., Sep 26, 2012.

  1. macrumors regular

    Jun 13, 2012
    I have moutain lion and i got the beacball for over 35/40mins, i tried use keys to force kit and it just was not working.

    I powered off the mac with power button, and now when i reboot screen it allows me to enter password but stays on beachball for many hourrs.

    Is there any way to create a usb recovery if I cannot access mac or how will i fix this problem?

    I cant do a fresh install as Id need to turn on the laptop for this to happen, is there a recovery usb you can download and load from start to repair etc.
  2. macrumors P6


    Jan 23, 2005
    Try holding command-r (both keys) when you start and that will takr you to the recovery partition. In the Utilities menu start Disk Utility then run repair disk and see if that helps.
  3. thread starter macrumors regular

    Jun 13, 2012

    It didnt, but i clicked install new OS. It connected to my net then and took 2hrs to downlaod and then it allowed me log in, but i thought it would give me fresh OS, everything is still there?
  4. thread starter macrumors regular

    Jun 13, 2012

    So I gave my MBP hard shutdown.

    It would not allow me log on when it booted up, it would allow me enter password but then constant
    spinning beacball.

    I rebooted and installed new OS (downloaded from net so it took 2 or so hours)
    When it was done it was not a fresh install, but had me login and i logegd in and now im gettin constant spinnign beechballs, i force quit every program open.
    It took a long time for it to shut down.

    I booted backl up and went into safe mode.

    It worked very slow. Lagging, but no beachball.

    I ran disk utility, verified/repaired permissions.
    Also on boot up it and verifed/repaired disk errrs.

    This is where I am now, so instead of a fix. Im thinkin fresh reinstall
    Still having problems.

    What else can be done?
    Is there anything I should do with the disk or anything before downloading ML AGAIN AND CREATING USB AND DOING FRESH INSTALL?
  5. macrumors P6


    Jan 23, 2005
    A command-r boot will get you to that same screen you used to install and should look like this. Click Disk Utility and then repair disk to see if that helps.

  6. thread starter macrumors regular

    Jun 13, 2012

    i done that already yeah, im going to try reinstall once i download to usb. il check disk before install 2. see how it goes.
  7. macrumors 6502a

    Jan 23, 2010
    San Diego, CA USA
    You could be having problems with a failing hard disk. If there are disk errors, the whole machine will slow to a crawl.

Share This Page