1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Macbook 32bit/64bit?

Discussion in 'Mac OS X 10.7 Lion' started by moonchilddave, Jul 28, 2011.

  1. macrumors regular

    #1
    I have an early 2008 (White) Macbook that I did a clean install of Lion on. One thing I noticed when looking around was in the System Profiler, if I click on software it says "64-bit kernel extensions: No". Now I thought Lion only ran in 64bit, and when I boot up, it tells me my Apple USB modem can't be used. I was under the impression that was because the kernel driver for the modem was 32bit only - but System profiler says that 64-bit extensions aren't enabled... I'm a little confused.
     
  2. macrumors 68030

    #2
    Lion is 64-bit but the Apple USB modem does not seem to work under Lion
    http://forums.macrumors.com/showthread.php?t=1193996&highlight=usb+modem
     
  3. macrumors regular

    #3
    If that is the case, I don't understand why my System Profiler lists 64-bit kernel extensions as "no" then...
     
  4. macrumors 68030

    #4
  5. macrumors P6

    Intell

    #5
  6. hekokimushi, Jul 28, 2011
    Last edited: Jul 28, 2011

    macrumors regular

    hekokimushi

    #6
    my C2D shows 64bit Kernel Extension : Yes
     
  7. macrumors 68000

    #7
    That is strange. Have you tried calling AppleCare?
     
  8. macrumors regular

    #8
    I found this thread with people discussing exactly this issue...

    http://att.macrumors.com/showthread.php?t=1193861

    I have a Macbook 4,1 (Early 2008 White) 2.1G C2D. It is apparently running 32bit, even though it apparently has a 64bit processor and 64bit EFI:

    Daves-MacBook:~ dave$ ioreg -l -p IODeviceTree | grep firmware-abi
    | | "firmware-abi" = <"EFI64">

    System Profiler shows: "64-bit Kernel Extensions: No". Looking at Activity Monitor most things say "Intel (64bit)" but some just say "Intel". Color me still confused.
     
  9. macrumors regular

    #9
    Anyone know where the Apple USB Modem kernel extension is located in 10.6.8? I'm wondering if I copied it over to Lion and restarted, if I'd have my modem back.
     
  10. macrumors P6

    Intell

    #10
    I think the Apple USB modem has been completely dropped from Lion.
     
  11. macrumors regular

    #11
    Well, my thinking was - since my copy of Lion is running a 32-bit kernel - couldn't I copy the kernel extensions over from Snow Leopard? Or is there a bit more to it than that?

    I found this on my SL partition:

    /System/Library/Extensions/IOSerialFamily.kext/Contents/PlugIns/MotorolaSM56KUSB.kext

    I copied that over to the same place on Lion (preserving ownership/permissions) - but no luck. Is there more to it than that???
     
  12. macrumors P6

    Intell

    #12
    It may be more than that. Apple might have blacklisted the modem to prevent it from being used.
     
  13. macrumors 6502

    #13
    I was trying to help someone else figure this out a while ago.

    There seems to be a physical restriction on those MacBooks from booting into the 64bit kernel, despite the fact the hardware and EFI support it. Holding '6' and '4' doesn't force it, even adding the kernel flag 'arch=x86_64' to com.apple.Boot.plist doesn't work, the machine just won't boot into 64bit mode.

    The iMac 5,1 and the MacPro1,1 only have EFI32, but they're also entirely capable of running 64bit mode, but also can't, though there are other machines that have EFI32 but have 64bit capable hardware that boot into the 64bit kernel mode by default.

    Personally, my MacBookPro 4,1 boots into 64bit mode by default.

    There is a 32bit kernel mode in Lion, but all the core apps (like finder etc) are only written in 64bit, so you still can't install it on a 32bit machine. Running Lion on a 32bit machine by removing 'platformsupport.plist' only worked in DP1 because Finder still had a 32bit version, but since DP2, this was removed. You can however install Lion on something like an older Core Duo Mac Mini which has been upgraded to a C2D (check out iFixIt, they do really helpful guides on how to achine this, as well as many other things).

    Hope this helps mate.
     
  14. macrumors regular

    #14
    It was more than that... I now have my Apple USB Modem working with Lion perfectly (dialup and fax both work)! A poster in the Apple Discussions thread above found a workaround... I forgot to copy over the audio driver, you need to copy both (and be in 32bit mode I think):

    /System/Library/Extensions/IOSerialFamily.kext/Contents/PlugIns/MotorolaSM56KUS B.kext
    /System/Library/Extensions/SM56KUSBAudioFamily.kext

    So, apparently Apple didn't blacklist it - they just didn't bother to include the drivers.
     

Share This Page