MacBook Air hangs for a few moments on wake

Discussion in 'MacBook Air' started by someguy, Oct 27, 2012.

  1. macrumors 68020


    Dec 4, 2005
    Still here.
    I just picked up a new base-model 11" MacBook Air and I love it. I was going crazy without a Mac since I left my job 2 weeks ago.

    I have one minor complaint, and I wanted to see if this was normal or if there was something I could tweak in the settings somewhere that might help.

    When the machine wakes from sleep, I immediately see the login screen which requires my password before the system can be used, however there is a good 3-5 seconds before I can actually begin typing.

    I know this probably seems nit-picky of me, but I figured if the system can wake that quickly, with an i5 and solid-state disk, I would be able to begin typing more quickly. Is this just normal behavior for Mountain Lion on a base-model MBA?

    tl;dr: My MacBook Air has a 3-5 second delay after waking, before I can enter my password to unlock the system. Is that normal?
  2. macrumors 68020


    Oct 27, 2010
    HR 9038 A
    I get this on mine too, but only if it's been off for a while. Figured it was normal
  3. macrumors 68020


    Feb 16, 2012
    This happens but only for about a second on my rMBP
  4. macrumors newbie

    Aug 24, 2011
    Same happens to my MBA '11 2011, but after being sleep for a while.
  5. macrumors 601

    Aug 27, 2012
    Mine does the same.

    Coming from a 10 years old Windows that wakes up in 10-15 seconds, I have a low-bar expectation! :)
  6. macrumors 6502

    Jan 6, 2008
    New York
    It's normal. A power saving feature.

    However it is possible to disable it, which I did and now my computer wakes instantly.

    Google it. It's a terminal command setting.
  7. macrumors 6502a


    Jan 7, 2011
    What do I google? :eek:
  8. thread starter macrumors 68020


    Dec 4, 2005
    Still here.
    I think I found what AeroUK is referring to. See the answer from Inspire48 on this page:

    The short answer is that running this command will change the hibernate mode your Mac uses, eliminating the delay I am referring to:
    sudo pmset -a hibernatemode 0
    Note that I have not tested this and can't confirm that it works, or even that it won't cause issues with your Mac. :)
  9. macrumors 68020


    Dec 5, 2009
    That link had some good info. At first the 3 second delay on my 2012 13" MBA was annoying, but I got used to it. And now that I know it's supposed to do that, it makes me feel better.
  10. macrumors 6502

    Jan 6, 2008
    New York
    Guys I changed mine to the '24 hour' setting and it is amazing. My MBP retina now wakes instantly.

    Apple should make this a choice on set up. I strongly recommend that you change this to set it to instant wake. Makes things a lot better.



    Change MacBook Wake Up time with terminal command:

    Start Terminal in Application -> Utilities -> or type Terminal in the spotlight Search.

    Type sudo pmset –a standbydelay 86400

    This is all I did
  11. macrumors member

    Mar 24, 2009
    Found this when i first bought my mbpr now everything is how I remember my previous macbook Pro. Will be adding this to my Macbook Air also when I get within the next few weeks.

Share This Page