Macbook and slow wireless connection

Discussion in 'Mac Accessories' started by markjago, Jun 12, 2007.

  1. macrumors newbie

    Jun 12, 2007
    I have trouble reaching high speed when connecting with AirPort to my BT Voyager 2110 router. Connecting with a cable works great.

    It seems to be a problem many people have that their wireless connection between the Mac and a router gives only a fraction of the transfer speed compared to when when using a PC and connecting wirelessly to the very same router. Is Mac more sensitive and have compatibility problems? How do I benefit from the same speed I get with PC to my router?
  2. macrumors member

    May 19, 2007
    This could be a setting problem, or maybe your router doesn't support g, only a and b. But I checked and according to the product page your router does support g. If it is a setting issue maybe you only have your wireless broadcasting in a/b. If it's an option you want to set this to auto. Or on your macbook you may have it only picking up in a/b. Find the setting in airport telling it to only look or connect to g networks or whatever.
  3. thread starter macrumors newbie

    Jun 12, 2007
    As far as I am concerned the router should be rather normal and modern. Maybe it is, as you say, a matter of finding the settings. I have specified 802.11g on the router, switched off any turbo features. Still the same problem. With regards to the settings on the Macbook I find them rather difficult to understand. I think I'm using default settings. Can't find where to configure specific network settings in detail.
  4. thread starter macrumors newbie

    Jun 12, 2007
    I solved the problem I described above. I changed the channel on the router to 11. Tech support told me that Macbook prefers 11, then 2 and then 6. I tried number 2 yesterday and it was still bad. However, channel 11 solved my problems. Now the wireless is fast as with cable.
  5. macrumors regular

    Oct 29, 2006
    My iBook would also show full wireless signal from my router. My MacBOok using the same router, and located in the same place) usually shows 3/4 bars. I'm getting download speeds of almost 600KB/s (seriously) when my MacBOok shows 3/4 signal. I'm more than happy with my ultra fast internet, but confused as to why it doesn't appear as full strength.

Share This Page