Macbook CD Keyboard Issue

Discussion in 'MacBook Pro' started by Agurri, Feb 8, 2007.

  1. Agurri macrumors 6502

    Agurri

    Joined:
    May 8, 2005
    Location:
    Québec, Canada
    #1
    Hello guys,

    I have 2 issues with my macbook keyboard.

    1)The first problem is the repeating function ... wherever I put the slide in the system preference, from the slowest to the fastest, the repeating key is not fast or slow at all .. it is a constant speed. Can anyone help me with this ?

    2)The second problem can be find while playing games. (The problem is kinda hard to explain, but I'll try). Let's say we are playing a first person shooter, withhe stock w, a , s, d, moving configuration. When I press w to go foward, no problem, but if I wanna go diagonaly top-right, I have to press the d key after the w key. But it won't work. If i press w, then d, in theory, I would go top-right, but it will only go right. And if I unpress the d key, I would go foward, but no, the player just stops moving. The problem can be bypassed by pressing w and d at the same time, then the keyboard acts "normally". It looks like if the keyboard can,t manage having 2 key pressed one after another.

    Thanks, Olivier
     
  2. Martin. macrumors member

    Joined:
    Feb 6, 2007
    Location:
    Calgary, Canada
  3. Agurri thread starter macrumors 6502

    Agurri

    Joined:
    May 8, 2005
    Location:
    Québec, Canada
    #3
    Of course. And just to make sure ... I have a Macbook, CD, 2hz white, 2gb ram. Running 10.4.8

    One of my friend who have the same Macbook, but with C2D doesn't have the keyboard w a s d problem.
     
  4. iW00t macrumors 68040

    iW00t

    Joined:
    Nov 7, 2006
    Location:
    Defenders of Apple Guild
    #4
    From the way you describe your game it really sounds like the fault lies with the developer of the game and not the Macintosh branded computer.

    What game is it anyway?
     
  5. Agurri thread starter macrumors 6502

    Agurri

    Joined:
    May 8, 2005
    Location:
    Québec, Canada
    #5
    it's for all games. I played quake 3 and world of warcraft, and the same problem occurs.

    I have windows installed on the computer, and it works without a problem ... so if it's not the games ... or the keyboard itself, it could be the OS ? But , as I said previously, my friend has a C2D Macbook and he doesn't have the problem...
     
  6. Selenolycus macrumors regular

    Joined:
    Feb 23, 2006
    Location:
    Northern Hemisphere
    #6
    Have you tried playing with an external keyboard? This could at least help isolate the problem.
     
  7. Agurri thread starter macrumors 6502

    Agurri

    Joined:
    May 8, 2005
    Location:
    Québec, Canada
    #7
    Hum, I have an external keyboard at home (currently at school), but i'll try when I'll come back home tonight. What I am sure of is that the problem #1 is still there if I use the external keyboard, but I'm not sure for the game problem.

    I'll check tonight.

    Thanks, Oliver
     
  8. Agurri thread starter macrumors 6502

    Agurri

    Joined:
    May 8, 2005
    Location:
    Québec, Canada
    #8
    Ok, I tried on my Apple External Keyboard, and the problem still occurs. But I realised something. The problem is there when I play WoW on Mac OS. The problem is there when I play Quake 3 via CrossOver. The problem isnt there when I play Quake 2. (I have the retail game, with the quake 2 x 1.1 patch applied.) Do you guys know what I should do ?

    Thanks, Oliver
     
  9. Agurri thread starter macrumors 6502

    Agurri

    Joined:
    May 8, 2005
    Location:
    Québec, Canada
    #9
    So, anyone can help with either the 1st or second problem ?
     
  10. iW00t macrumors 68040

    iW00t

    Joined:
    Nov 7, 2006
    Location:
    Defenders of Apple Guild
    #10
    I just realised a possible cause...

    Did you turn on Sticky Keys under System Preferences->Universal Access? :mad:

    Turn that off.
     
  11. Agurri thread starter macrumors 6502

    Agurri

    Joined:
    May 8, 2005
    Location:
    Québec, Canada
    #11
    Wow, it worked out !!! Thanks iW00t !!! Now that the 1st problem is solved ... what about the second !!!!

    Yay !
     

Share This Page