MacBook doesn't go to sleep by itself

Discussion in 'Mac Basics and Help' started by TWLreal, Aug 27, 2006.

  1. TWLreal macrumors 6502

    Joined:
    Jul 9, 2006
    #1
    Here's a fact:

    1. You can put a MacBook to sleep via the Apple menu, closing the lid or keeping it inactive for a certain amount of time.
    Here's my situation:

    1. I can put my MacBook to sleep via the Apple menu. I then need to press a key from the keyboard to wake it. That works.
    2. I can put my MacBook to sleep by closing the lid. I then need to open it again to wake it. That works.
    Now here's the problem. The thing won't go to sleep by itself.

    I've only noticed this recently. I used to be able to leave it inactive for a short while, the screen saver would kick in, later the screen would turn off and then it would go to sleep. How do I know? The white sleep light blinks and I have to press a key to wake it.

    What happens now? I leave it inactive, the screen saver comes up, then the screen goes black with the sleep light on but it is solid. As far as I know, it's still running full power, just that the screen is off. How do I know? I can wake it by moving a mouse or the trackpad, it's simply not sleeping. The hard drive is still spinning. I don't hear it "waking up" as it would normally.

    This is rather annoying because it uses a lot more power than it would had it been in sleep mode.

    Now, I know resetting the PMU would probably fix this but I would like to know if it has something to do with the system preferences before I do that.

    Here is the energy saving profile I use in the attachment.
     

    Attached Files:

  2. EricNau Moderator emeritus

    EricNau

    Joined:
    Apr 27, 2005
    Location:
    San Francisco, CA
    #2
    I've had this problem twice (on two different Macs), but to be honest, I have no idea how to fix it. In both cases it went away by itself (I think, I don't recall doing anything).
     
  3. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #3
    I get it every now and then on my iMac and either resetting the PMU (as you said) fixes it or it gets remedied by a system update. In fact, my iMac is acting like this right now but I can't be bothered fixing it. I'll probably just wait 'til 10.4.8. Oh, and I don't think it has anything to do with the preferences. :)
     
  4. TWLreal thread starter macrumors 6502

    Joined:
    Jul 9, 2006
    #4
    I've noticed it only has the problem when I am connected to the Internet.

    If I'm running the notebook with no connection to anything, it will sleep by itself correctly after the set period of time in the energy saver panel.

    However, if I'm connected to the Internet, it won't go to sleep automatically.

    Anyone?
     
  5. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #5
    Well, have you ended up trying the PMU reset? It won't do any damage. :)
     
  6. Kernow macrumors 65816

    Kernow

    Joined:
    Sep 30, 2005
    Location:
    Kingston-Upon-Thames
    #6
    I've had this pretty much permanently on my dual 2.0 G5 - system updates and resetting PMU have done nothing. It doesn't bother me much as I'm so used to manually sleeping it, but it would be nice to know why it is doing this.
     
  7. TWLreal thread starter macrumors 6502

    Joined:
    Jul 9, 2006
    #7
    Not really.

    That's my last option. Because the way I see it, something happened to the system that the user didn't initiate. The user shouldn't be required to do a manual PMU reset to fix this.

    I haven't tried disabling the wake on LAN option but really, I didn't change any setting so I don't except it to do anything.
    At least it's a freaking tower.

    A notebook that doesn't sleep drains a hell of a lot of power. Totally kills my battery life.
     

Share This Page