Macbook doesn't sleep automatically

Discussion in 'Mac Basics and Help' started by Megatoerist, May 4, 2011.

  1. macrumors newbie

    Joined:
    May 25, 2009
    #1
    Hello all,

    I've noticed yesterday that my macbook doesn't go to sleep according the schedule I set under System Preferences>Energy. The screen switches off just fine, the computer just doesn't go to sleep.
    When I close the lid, everything works just fine.

    Extra info: I'm running 10.6.7 on a late 2009 macbook pro. I've already tried repairing permissions, purging caches, booting into safe mode and quitting all applications except Finder. Nothing in the console seems to be resetting the sleep timer, but I just can't get my macbook to go to sleep on its own.

    Any suggestions?

    Thanks!
    -Megatoerist
     
  2. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
  3. thread starter macrumors newbie

    Joined:
    May 25, 2009
    #3
    Been there, done that. :)
    - Bluetooth switched off
    - Nothing shared over the network
    - No external keyboard and mouse present
    - No USB/peripherals connected
    - Spotlight isn't indexing
    - Safe mode already tried
    - I hear just the fans
    - Energy saver preferences are normally set to default, but I have them both at 1 minute delay for now.

    Thanks!
    -Megatoerist
     
  4. GGJstudios, May 4, 2011
    Last edited: Feb 11, 2015

    macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    Look at Activity Monitor to see what processes you have running. Be sure you're looking at "All Processes" and not just "My Processes". Also, use Google to search the forum for other threads with this same question, to see what others found to be the cause.
     
  5. macrumors 68030

    Joined:
    Sep 21, 2011
    #5
    Did you ever figure out how to fix it? I've got the same problem which magically appeared a few weeks ago...
     
  6. thread starter macrumors newbie

    Joined:
    May 25, 2009
    #6
    Nope, the issue is still there even after an upgrade to Lion and all subsequent patches... :(
     
  7. macrumors newbie

    Joined:
    Jul 21, 2010
    #7
    Never slept since 207

    I have had this issue with my Mac Pro (2.1) since 2007 and I have never been able to resolve this, even with Apples help whilst in Apple Care.
     
  8. macrumors newbie

    Joined:
    May 8, 2012
    #8
    Same...

    Any success in finding the solution? For me the problem magically appeared a couple of weeks ago, hard to tell exactly when. I've been trying to figure out what could be the cause of the problem, maybe a new program I installed or something. But the only thing I can come up with is that I bought a iPad 3 around the same time the problems started. Just a coincidence maybe?
     
  9. thread starter macrumors newbie

    Joined:
    May 25, 2009
    #9
    Solved! (kind of)

    Since upgrading to Mountain Lion, everything works again. It's not a real solution if you don't plan on upgrading, but for me, it's ok. :)
     
  10. macrumors newbie

    Joined:
    Nov 21, 2012
    #10
    Sleep mode

    Hi, I have the same problem with the seep mode. I am o a snow leopard. have you found any solution?
     

Share This Page