MacBook froze on update. Now it won't boot at all

Discussion in 'MacBook Air' started by usmaak, Mar 29, 2013.

  1. macrumors regular

    Apr 13, 2012

    I was updating my wife's macbook air (mid 2012) with the latest updates. It got stuck in the middle of the update. It said 5 minutes remaining for two hours. So I pressed an held the start button for five seconds, and the computer shut down. When I started it up, I got a white screen with a folder in the middle of the screen. In the middle of the folder, is a blinking question mark.

    In hindsight, it probably wasn't the smartest thing to just shut it down like that. But I couldn't do anything else with it. No keys worked. It was just sitting there.

    Any ideas how I can fix it? Because it's a mid 2012 model, there is no installation software with it. It all came from the app store.

  2. macrumors 6502

    Mar 29, 2013
  3. thread starter macrumors regular

    Apr 13, 2012
    Thanks for the link. Unfortunately, it did no good. I get into internet recovery. It takes about 15 minutes to load. Then I have options to reinstall or run disk utilities. So first, I ran utilities. It does not let me do anything to the disk. All of the options are greyed out and unaccessible. So I tried reinstalling OS X 10.7. It would not let me. I got an error about the hard drive not having journaling enabled. It told me to go back to disk utilities and enable it. But like I said, there are no options that I can use in disk utilities. So I went online and found out how to create a bootable USB drive with the OS X install on it. I downloaded OS X and created the flash drive. But there is no way for me to boot to the flash drive. According to instructions I found on the internet, I am supposed to hold down the option button and turn the computer on. I'm supposed to hold the option button down while the mac is booting up. Eventually I'm supposed to get an option of where to boot from. That never comes up. All I get is the internet recovery option.

    I'm at a complete loss. I've been working on this all night, and I am no closer to an answer than I was four hours ago. Frustrated.
  4. macrumors 6502

    Mar 29, 2012
    Turn your Mac off.
    Insert the usb you made.
    Turn the Mac on.
    As soon as you turn it on KEEP on holding the option key on your keyboard.
    Its the 3rd key on the bottom left
    Holding the option key, your usb will appear on screen,
    Go from there.
  5. macrumors 603


    You say you see a question mark, this could be because the Volume is not blessed, if this is so you can do so from Terminal in Recovery, you need to start from Recovery, Open Disk Utilities, click on the Macintosh HD, get info and look what the Disk Identifier is.
    It should be something like disk0s1 or similar, write it down, open Terminal and enter the following command:

    bless --folder=/Volumes/****/System/Library/CoreServices --file=/Volumes/****/System/Library/CoreServices/boot.efi --setBoot
    Hit Enter
    Enter Password.

    **** = the disk Identifier which you wrote down.
    **** could also be the Volume name.

    Reboot and see if this worked.
  6. thread starter macrumors regular

    Apr 13, 2012
    I went ahead and gave this a try. The only way that I could get into recovery is by plugging in my bootable flash drive. I typed everything exactly as you have above. I replaced the **** with disk1s2. That's what disk info shows. When I hit enter, I get the following response:

    Can't determine mount point of '/Volumes/disk1s2/System/Library/CoreServices' and ' '

    Now that I can get to the install USB flash drive, I tried to reinstall the OS. When I got to the window to select the drive, my HD was there, but when I clicked on it, it says This disk is locked. The install button is greyed out, and the only thing that I can do is shut down the computer.
  7. macrumors 603


    Hmm, I know you could also do this in Single User Mode, it can't determine the mount point because it might not be mounted so you have to mount the disk first, or (as below) the disk has FileVault2 enabled, it won't work.

    It's probably locked because it has FileVault2 enabled, initialise the HD, should be possible.
  8. thread starter macrumors regular

    Apr 13, 2012
    When I go into recovery, the only option that's available for the disk is Verify. All other options are greyed out. I'm ok with reformatting and reinstalling, but it won't let me do either.

    I'm a Windows guy who's trying to be a Mac guy. I'm pretty clueless about any of this. Is this even something that I can fix on my own? Or do I need to bring it to Apple?
  9. macrumors 603


    Is the SSD greyed out, I mean the not the Macintosh HD but the SSD itself?
  10. thread starter macrumors regular

    Apr 13, 2012
    Well, what a difference a day (and some sleep) makes. I was pi$$ed off and tired last night, so I didn't realize that I wasn't even looking at the right thing. The disk utility has different items in the list on the left side. I see the Macintosh HD that you are talking about. It also says disk1, with Mac OS X Base system underneath it. That's what I was looking at. When I actually select Macintosh HD, all of the options are enabled.
  11. macrumors 603


    :D, yeah, I know the feeling(tired)
  12. thread starter macrumors regular

    Apr 13, 2012
    So I did the command that you gave me above, but substituted Macintosh HD for the ****. I also enclosed the paths in single quotes. It seems to have worked. My computer is now booting up correctly once again. Thanks so much for your help on this problem!!!
  13. macrumors 603


    Big grin, I actually said that in that post, you could use the HD name.

    So, in the end the only thing which was wrong was that the System was not blessed and that's why you got the question Mark.

    Happy it's solved, take care.
  14. thread starter macrumors regular

    Apr 13, 2012
    Yea. I'd have had no idea, if you hadn't said it in your post. I'm clueless about this stuff.

    That ended up being the problem. Now that I'm back in, I tried running the update again. It failed again, and I'm back to the folder with the question mark. But at least I know how to get past that. This time it said that the update file was corrupt and that it would redownload it. So I'm making progress, even if it is slow progress. :)

    I spoke too soon. It is no longer seeing my hard drive. Now the internet recovery is coming up again. I guess that I'll let it load, and see if that can see my HD. If it can't, then I'm back in a state of not knowing what to do. :S
  15. macrumors 603


    Hmm, wish you downloaded it directly from Apple instead of using Software Update, normally if you download the Combo Update it will do the trick.

    So, Holding the Option key does not work, hold and keep holding it until the boot manager arrives.
  16. thread starter macrumors regular

    Apr 13, 2012
    When I do that, all that arrives is the internet utility. I'm letting it load now. Hopefully it will give me the option to run the command that you gave me. So if my HD does not show up, that means that it's not mounted, right?

    The internet utility just got done loading. The Macintosh HD is not even showing up in the list. Only:

    Mac OS X Base System
  17. macrumors 603


    You can open Terminal from the Menu Bar in Recovery, but you should know I think, how did you do it before, from there I am pretty positive.

    GMT +7, get back tomorrow.
  18. thread starter macrumors regular

    Apr 13, 2012
    I'm not sure. The Macintosh HD was there before, and now it's not. I tried running the terminal command, but it said that it did not exist. When I try to boot while holding the Options button, the only thing that comes up is the bootable flash drive. Before, I used to also get the hard drive. But only sometimes. I know this is just rambling, but I really am not too sure what I'm doing.

Share This Page