Macbook goes to sleep too soon

Discussion in 'macOS' started by pmd, Jun 2, 2006.

  1. pmd macrumors member

    Joined:
    Jan 14, 2004
    Location:
    Melbourne (Previously UK)
    #1
    I've set my Macbook to go to sleep when it's on mains power after 3 hours (so I can leave it downloading or doing a large compile), but it goes to sleep after just a few minutes. If I'm using it, as expected, it won't go to sleep, so it's not a case of a dodgy battery as far as I can tell.

    It replaced a G3 iBook which I had for 4 years and never saw this problem. I've checked and double checked all the settings. It also fails to respect the sleep time when running off the battery.

    I've reset the PMU but it didn't make any difference. I can't find any other mentions of this problem anywhere else so I'm a bit stuck until I can call Applecare at the weekend.

    Paul
     
  2. jelloshotsrule macrumors G3

    jelloshotsrule

    Joined:
    Feb 7, 2002
    Location:
    serendipity
    #2
    does it go to sleep fully, or does the display just turn off? either way, i'm not sure what's causing it, but it could certainly make a difference.
     
  3. pmd thread starter macrumors member

    Joined:
    Jan 14, 2004
    Location:
    Melbourne (Previously UK)
    #3
    It goes to sleep fully - the screen blanks, the light on the front starts pulsing and when I wake it the wireless network connection has to be restarted, with any downloads etc. in the state they were in as it went to sleep.

    Paul
     
  4. pmd thread starter macrumors member

    Joined:
    Jan 14, 2004
    Location:
    Melbourne (Previously UK)
    #4
    Fixed!

    I've managed to fix the behaviour somehow - I simply turned off 'Put hard disk to sleep when possible'. As soon as I did that then I got the behaviour I was expecting.

    Thinking that the hard disk sleeping behaviour had also changed (ie. that now it's supposed to also blank the screen, which would be odd), I turned the drive sleeping back on...and I still get the behaviour I expect!

    I can only guess that unchecking and checking that option has reset something - maybe the settings I migrated from the iBook didn't quite correspond with how the Macbook works?

    Cheers,

    Paul
     

Share This Page