MacBook isn't loading!! Help!

Discussion in 'MacBook' started by Topher15, Jul 13, 2009.

  1. macrumors 6502a

    Topher15

    Joined:
    Oct 22, 2007
    Location:
    London
    #1
    About 15 minutes ago my MB locked up and the screen turned dark blue.

    I turned it off and then pressed the power button to turn it back on yet almost instantly I see a white screen. Nothing else happens. Edit: just to add, it takes a about 5 seconds for the hard drive to start spinning; it then appears to slow down after a minute or so. It acts like it is waking from sleep rather than actually loading the OS, even if I take out the battery.

    It has been running for the last few days pretty much constantly (via mains) so maybe it just over heated?

    Any ideas what could have caused this?

    Thanks. Help always appriciated. :apple: :cool:
     
  2. Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    Can you boot from the Restore Disks by holding down "C" after the start up chime?
    Do you have another Mac, with which you can save your data via Target Disk Mode?

    Unless you MacBook has run the several days with the CPU constantly at 100% it sure hasn't overheated.

    Do you still have warranty?
     
  3. macrumors 601

    liketom

    Joined:
    Apr 8, 2004
    Location:
    Lincoln,UK
    #3
  4. thread starter macrumors 6502a

    Topher15

    Joined:
    Oct 22, 2007
    Location:
    London
    #4
    Thanks for the replies. As I said in my edit it doesn't appear to load so holding the keys when I turn it on doesn't seem to work.

    I do have an iMac however it has a dead hard drive (which is why I've been on the MB for the past week. I only have AppleCare for the iMac.
     
  5. thread starter macrumors 6502a

    Topher15

    Joined:
    Oct 22, 2007
    Location:
    London
    #5
    Okay I reset PRAM and now get the chim at start up.

    I tried pressed the Option key at start up. I heard the disc drive spinning, about a minute later the disc ejected itself at the Apple "poof" animation appeared (other than that all I get is a white/gray screen with the mouse pointer).

    I also tired holding the C key. That didn't do anything other than the disc ejecting after a minute or so of the drive spinning.

    Edit... I got into OS X Installer. Fingers crossed.
     
  6. macrumors 601

    liketom

    Joined:
    Apr 8, 2004
    Location:
    Lincoln,UK
    #6
    love it when a plan comes together
    [​IMG]

    Keep us posted if you get in
     
  7. thread starter macrumors 6502a

    Topher15

    Joined:
    Oct 22, 2007
    Location:
    London
    #7
    Well so far... not good. :(

    Disk Utility only shows the DVD drive (no hard drive!)

    When I turn on the MB without the disc in the drive I get the blinking questionmark folder! :eek:

    That means I have TWO dead Macs on my desk at the moment!! Bad Apple! :mad:

    I'm currently downloading TechTool Deluxe via a Windows PC. Hopefully this can fix both. The iMac HD does show up in Disk Utility and does load up after a Time Machine restore so I hold out hope for that one (otherwise I'll get AppleCare to replace it.)

    I don't have AppleCare for the MacBook and am past my one year warrenty (it was a referb ayway) although I can just buy a 120GB hard drive and stick that in.

    Boy o boy not good. To think I was happily watching episodes of 24 and browsing the net just a few hours ago.
     
  8. macrumors regular

    Kat King123

    Joined:
    Jan 3, 2009
    #8
    Press the Power button, and immediately press and hold down the Command key and the S key as the machine starts up. This boots you into Single-user mode and you should see white text appear on the screen.
    When you see the # command prompt, type /sbin/fsck –fy ) and hit Return.This could take 15 minutes or so—or even longer...
    If and when you see the message “File System was modified,” repeat the step above again, and again, until 
you finally, hopefully, see a message saying, “no problems were found.” When that happens type reboot and hit 
Return again. Good Luck
     
  9. thread starter macrumors 6502a

    Topher15

    Joined:
    Oct 22, 2007
    Location:
    London
    #9
    Kat King123 - Thanks for the suggestion. I couldn't didn't even start up in Verbose or Single-User mode, so no luck. :(

    I'm thinking the drive cannot mount at start up, or the drive is simply toast.

    I've downloaded (on a Windows laptop) TechToolDeluxe to try to fix the comuters (I download the CD version for the MacBook and the DVD version for the iMac).

    I'm having trouble burning the .dmg file.

    The process described on the Apple web site is quite simple... select the disk image in Disk Utility and click burn, but with two dud Mac that seems out of the question.

    To get around this I loaded the .dmg files onto my old iPod, plugged it into the MB and tried to burn it (via an external DVD burner). The iPod and the files show up fine, however it just keep spitting out the CD/DVD. Can anyone confirm whether it is possible to burn discs in Disk Utility when in OS X Installer?

    I've tried to burn the disk in this Windows laptop with both MagicISO (which converts the .dmg into an .iso file, then burns the disk) and MacDrive 8, yet neither seem to be reading.
     
  10. macrumors newbie

    Joined:
    Jul 16, 2009
    #10
    almost exactly the same thing happened to me today. The only difference is my MB restarted after a system update (safari upgrade). Installed, restarted, got the installation message before it shut down, then it loaded back up and hung on the apple with the spinny thing. Restarted in verbose mode and got kernel panics galore. Tried restarting a couple more times and actually got to the user name input screen once, but it wouldn't load the desktop. After that, I got nothing.

    I can't do any of the boot key combinations, so I can't load from my Time Machine backup or my install disk. I take that first back, if I hold option on startup, I get a mouse pointer on my white screen, but nothing else. Sadly, I haven't updated my TM backup in over a month. I really need a Time Capsule. :\ But I'm really hoping there's some way to save my data...
     
  11. thread starter macrumors 6502a

    Topher15

    Joined:
    Oct 22, 2007
    Location:
    London
    #11
    My problem is resolved... I just got a new drive. :p
     
  12. macrumors 6502

    Joined:
    Jun 25, 2007
    Location:
    North Carolina
    #12
    Man you must either have terrible luck or are very hard on those hard drives for them to both die in one week! What do you do with your comps? They don't seem very old (24" aluminum iMac and Blackbook)
     
  13. thread starter macrumors 6502a

    Topher15

    Joined:
    Oct 22, 2007
    Location:
    London
    #13
    Well my iMac drive went about a month ago, but because I was so busy I just transfered all my work load (which at the time was After Effects/Encore/Premier) to my MacBook, I guess I just over done the MB and it died before the iMac was repaired.

    At the moment I'm running TechTool Deluxe. It failed Directory Scan and Volume Structure, which it then repaired. Now I'm running Surface Scan which will take all night. If that doesn't work just have to take it in to get the drive replaced by Apple.

    That iMac has done me well over the last two years (since Sept 2007) considering I never turn it off! The MacBook was a refurb bought in early 2008.
     
  14. macrumors 6502

    Joined:
    Jun 25, 2007
    Location:
    North Carolina
    #14
    Yikes sounds like you have a long Friday night--I've had quite a few of those..hope you have some juice by your side to keep you company ;)! Good luck,
     
  15. thread starter macrumors 6502a

    Topher15

    Joined:
    Oct 22, 2007
    Location:
    London
    #15
    Well it's almost 1am here. I'm just gonna get it do its thing though the night. :cool:
     

Share This Page