Macbook pro 13" (A1278) battery/power issue

Discussion in 'MacBook' started by matx5, Aug 21, 2010.

  1. macrumors newbie

    Joined:
    Aug 21, 2010
    #1
    Hey all,

    Yesterday my macbook stopped working, when i pressed the power button nothing happened. So I decided to open it to see if I could fix it. I've found the problem but it's a really weird one:
    If I connect the power supply and press the on button, nothing happens.
    If I connect the power supply, disconnect the battery and press the on button, nothing happens.
    But if I connect the power supply, then press the on button and after that disconnect the battery the macbook starts booting.

    Has anyone had this problem before and knows what's the part to replace?

    Thanks in advance,

    Matjas
     
  2. Pax
    macrumors 6502a

    Joined:
    Dec 12, 2003
    #2
  3. macrumors 6502a

    Blondie :)

    Joined:
    May 12, 2010
    Location:
    Prescott, AZ
    #3
    I don't know that the SMC would really have an effect on this one...but it never hurts to try. You can also reset the PRAM (I don't even know what it stands for haha). Or, you can also boot in safe mode, and see if you can diagnose the problem from there. I've heard that the mac safe mode is accessed by holding down the shift key while pressing the power button. Hope some of this helps :eek:
     
  4. thread starter macrumors newbie

    Joined:
    Aug 21, 2010
    #4
    I've tried both the solutions but neither of them did the trick.
    I just noticed this post is in the wrong sub forum so I made a new one in the right sub forum here.
    So a mod can close/remove this one.
     

Share This Page