Macbook Pro and iBook battery issues

Discussion in 'PowerPC Macs' started by spjonesi, Aug 30, 2007.

  1. macrumors member

    Oct 10, 2006
    OK, so I have a brand new macbook pro. 2.4 ghz 4gb ram etc. I'm having a battery issue on it. IT IS -NOT- that the batteries are discharging to 97% or whatever when they are plugged in...

    It is that it neither of my computers do this! I transferred settings over from my iBook to my MBP and now it acts just as goofy. If they are plugged in with the battery, they show 100% charge all the time.

    The iBook started acting up after I replaced the hard drive and took it I kind of figured I just effed something up. On the iBook I reset the PMU and vram and it persisted so I left it as I was getting the new computer anyway.

    So the iBook doesn't do it, now it appears the MBP doesn't either. Am I being too picky here? I don't leave the MBP plugged in all the time, so is it that the MBP doesn't show a discharge as soon as the iBook did?

    Right now I've been sitting at 100% on my MBP for over an hour. Normal, or not?

    This is my last step before calling apple.

  2. Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    I'm not quite sure that you've got a problem... If you run the battery flat and then plug it back into the charger, does it immediately go to 100%? Is that the problem?
  3. thread starter macrumors member

    Oct 10, 2006
    Nope, that isn't the problem. If I let it discharge, it goes to whatever %. Then when I plug it in, the adapter goes orange, then it charges to 100%. But unlike my iBook when I first got it, it does NOT discharge the battery with the adapter plugged in (at least it doesn't appear to).


    edit: It does not immediately go to 100%, but it doesn't/didn't on my iBook either. It would go to say 50% then I'd plug in and it would charge to 100% and stay there. Not discharge like it did when it was new.

Share This Page