MACBOOK pro automatically logs me out immediatly after log in

Discussion in 'OS X' started by ajohndoea, Oct 20, 2009.

  1. macrumors newbie

    Joined:
    Oct 20, 2009
    #1
    I have a macbook pro 17" I upgraded to leopard a few weeks ago. Like it does normally, it asks if i would like to do a software update. It gave me five things which needed the update. I run the updates. It restarts and runs updates 1-5 restarted itself it seemed kinda glitchy cause it didnt come on right away. Once it was to the loggin screen; i log in (right password) and then after loading my desktop it logs me out. After repeatedly trying to log in and stay logged in, it logs me out continuously. I've reset the PRAM and the SMC but still it logs me out as soon as it loads the desktop. PLease help. I'm a musician and I need my comp all my work is on there. Thanks.
     
  2. macrumors member

    Joined:
    Oct 5, 2007
    #2
    try logging into console:

    at the login screen in the username tab type: >console

    this will take you to a black screen with white text,then it will prompt with username and password.See if you can log in from there.If you succeed in logging in,type logout this will take you back to the main login screen.Then try logging in regularly
     
  3. thread starter macrumors newbie

    Joined:
    Oct 20, 2009
    #3
    there is no username tab. Im the only user and there is only a place to type the password. I've tried to start in safe mode but that doesnt work either (it just stays on the loading wheel grey screen) I'm probably going to take it in today...but just need to try and fix it myself cause this is retarded.
     
  4. thread starter macrumors newbie

    Joined:
    Oct 20, 2009
    #4
    so i took my comp into the apple store. We couldnt do anything. Just went in safe boot and looked around repaired permissions and everything but it continued. After I left she recommended that i reinstall leopard. Safe boot works. JUst hold down shift for the entire time at startup untill the login screen appears (for me this took atleast 5 min , holding ect..) I am going to back up my whole harddrive and try reinstalling leopard.

    I've tried upgrading to snow leopard but problem persist. so I think the only way to fix this problem is to clean install the OS.

    I am able to log in with out safe boot when my airport is off. Software update doesnt work with airport but with ethernet. safari does the same thing. It might be a networking error with airport since i think the software update glitched out while updating the airport and others. I will comment an update asoon as i reboot everything and let you guys know. Thanks.
     
  5. macrumors 6502

    Joined:
    Jul 3, 2009
    #5
    do an archive and install. it might fix your problems without having to wipe all of your data
     
  6. thread starter macrumors newbie

    Joined:
    Oct 20, 2009
    #6
    solution

    I had to reinstall leopard. I'm happy i did it. It's performing much better. I didn't do an archive install. I diagnosed the main problem, when logging into the account the startup application "airport" would for some reason log me out. the software update utility in safe mode wasn't able to make a connection through the airport and would quit itself, so I turned off the airport and was then able to sign into my account normally. I still had some glitches with some programs.


    I used the restore tool in disk utility to duplicate my hard drive. From the source to destination tool.

    Im in love again.
     
  7. thread starter macrumors newbie

    Joined:
    Oct 20, 2009

Share This Page