Macbook Pro can't connect at 1000mbps LAN

Discussion in 'MacBook Pro' started by Simo1122, May 12, 2010.

  1. macrumors member

    Simo1122

    #1
    Hey All,
    For some reason my MBP 15" (2.53ghz) can't connect to my network at 1000mbps, only at 100mbps. Tried the exact same cable on a 13" MBP and it got 1000mbps.

    Any idea what would be causing it?

    This (I think) and another issue (I'm sure) has arisen since apple changed my logic board....
     
  2. macrumors regular

    #2
    check network utility for link speed/supported link speeds, below is an image similar to what you need to check:

    [​IMG]

    Regards,
    John
     
  3. macrumors member

    Simo1122

    #3
    100 mb/s it says.

    It also takes 10 seconds+ to gain internet connectivity once plugged in.

    On the other MBP it's pretty much instantaneous...
     
  4. macrumors regular

    #4
    Can you post the text under 'ethernet card' in the hardware section of system profiler?
     
  5. macrumors regular

    #5
    You've got your own network with 1Gb of speed? That's freakin' amazing :O

    Now ontopic, I have no idea. :)
     
  6. macrumors regular

    #6
    it would only require 2 machines with gigabit NIC's and a cat 5e/6 cable, and a gigabit switch, not that big a deal :)
     
  7. macrumors regular

    #7
    I have no idea what you're talking about.
    Can you point me in a direction so I can do some research?
     
  8. macrumors member

    Simo1122

    #8
    Type: Ethernet Controller
    Bus: PCI
    Vendor ID: 0x10de
    Device ID: 0x0ab0
    Subsystem Vendor ID: 0x10de
    Subsystem ID: 0xcb79
    Revision ID: 0x00b1
    BSD name: en0
    Kext name: nvenet.kext
    Location: /System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/nvenet.kext
    Version: 1.0.73
     
  9. macrumors regular

    #9
    there should be more there, listing the brand of card, .ie broadcom .... etc
    poke around system profiler, not just in the 'Network' section but also in the hardware section
     
  10. macrumors regular

    #10
    It's just like this:


    [​IMG]

    so I guess the only difference between a 'normal' LAN (local area network), i.e. two or more computers that are plugged into a switch. (http://en.wikipedia.org/wiki/Network_switch)

    and a Gigabit LAN is that the 'switch' is Gigabit capable (ie. 10 times faster than standard switch)

    and the computers plugged into it, are both relatively modern (ie. have Gigabit capable ports)

    does that make it clearer?
     
  11. macrumors member

    Simo1122

    #11
    Type: Ethernet
    Hardware: Ethernet
    BSD Device Name: en0
    IPv4 Addresses: 192.168.1.5
    IPv4:
    Addresses: 192.168.1.5
    Configuration Method: DHCP
    Interface Name: en0
    Network Signature: IPv4.Router=192.168.1.254;IPv4.RouterHardwareAddress=00:04:ed:d1:76:88
    Router: 192.168.1.254
    Subnet Masks: 255.255.255.0
    DNS:
    Domain Name: home.gateway
    Server Addresses: 192.168.1.254
    DHCP Server Responses:
    Domain Name: home.gateway
    Domain Name Servers: 192.168.1.254
    Lease Duration (seconds): 0
    DHCP Message Type: 0x05
    Routers: 192.168.1.254
    Server Identifier: 192.168.1.254
    Subnet Mask: 255.255.255.0
    Ethernet:
    MAC Address: 00:25:00:a5:14:58
    Media Options: Full Duplex, Flow Control
    Media Subtype: 100baseTX
    Proxies:
    Exceptions List: *.local, 169.254/16
    FTP Passive Mode: Yes
    Service Order: 0
     
  12. macrumors member

    Simo1122

    #12
    Annnnybody got a clue?
     
  13. macrumors 65816

    #13
    is the device you are connected to a rated at 1000mbps or 100mbps?

    You should find that the readings will change according to the capacity of the device you are connected to.
     
  14. macrumors 6502

    #14
    Just so that we don't overlook the appropriate setup: When you go to System Preferences/Network/Ethernet Connected/Advanced/Ethernet if you see "Configure Automatically" selected, then set it up manually to look like the screen capture then re-test.

    [​IMG]

    neil
     
  15. macrumors member

    Simo1122

    #15
    The router is rated for gigabit and if I try another computer in the same cable it connects to gigabit fine.

    I tried putting it into manual but it can't establish the connection when I do....
     
  16. macrumors 65816

    #16
    Time to contact AppleCare maybe?
     
  17. macrumors member

    Simo1122

    #17
    Hmm I might try a reinstall...

    Actually I might boot in windows and see if it can connect at gigabit. If it can I need to reinstall, if it can't bloody applecare here I come!
     
  18. macrumors member

    Koronis

    #18
    Have you tried another computer on the same cable? a damaged wire could cause it to only connect at 100 instead of 1000. Also try another port on the switch.
     
  19. macrumors member

    Simo1122

    #19
    Yep tried a 13" MBP. It can get 1000mbs.
     
  20. macrumors newbie

    #20
    Hi, did you eventually find a solution to your problem?

    I've recently just upgraded my network to gigabit speeds and very disappointed that I'm facing the same problem where my MBP ( 2.4Ghz C2D with 1st gen LED backlit ) refuses to negotiate a gigabit link. Forcing it to gigabit simply gives me an error about there being no cable connected.

    Every other device I have that supports gigabit connects to the same switch just fine at gigabit speeds. It's just this MBP.

    And to top it off, it's out of warranty and I don't have apple care
     
  21. macrumors 6502

    #21
    Are you using >=CAT5e cables? It's needed for gigabit networking.
     
  22. macrumors newbie

    #22
    I tried it with cat5e cables and it didn't work. Cat6 did. Oddly enough, all my other devices uses the same cat5e cable that I tried with the MBP and they work just fine.

    Guess the MBP is just being extra picky.
     
  23. macrumors member

    #23
    Did you find a solution I am having the same problem on a mac pro with one of the ports not connecting at gigabit to my switch. It will connect to my unmanaged switch at gigabit but won't connect to my managed switch at gigabit which I need.
     
  24. macrumors member

    Simo1122

    #24
    Yep, took it to apple and got the logic board replaced. Fixed now.
     
  25. macrumors G5

    Consultant

    #25
    Probably want to change first post title to [fixed]
    Edit, then Advanced

    5 port Gigabit switch = $20 if on sale
    Gigabit ethernet cable = few dollars each
     

Share This Page