Macbook Pro won't charge the battery

Discussion in 'MacBook Pro' started by Carlsen, Mar 11, 2007.

  1. Carlsen macrumors member

    Joined:
    Feb 20, 2007
    Location:
    Denmark
    #1
    Hi,

    I've had my MBP for some five months now.
    Yesterday the charge LED on the magsafe connector went out. Also, the battery stays at it's current charge (73%) as long as the connector is in.
    So the adapter apparently works, but doesn't recharge the battery.

    If the battery was faulty, wouldn't the charge drop to zero?

    I'll be calling Apple support tomorrow, but of there's any troubleshooting I can do now, I'd like to see what's wrong here now.
    I have no spare adapter or battery, so can't use that.

    I've tried resetting the NVram, no difference. Are there any other resets that could have an influence here?
     
  2. Abstract macrumors Penryn

    Abstract

    Joined:
    Dec 27, 2002
    Location:
    Location Location Location
    #2
    1. Repair Disk permissions by going to FINDER>UTILITIES>DISK UTILITY

    2. Try resetting the PMU on your laptop. I don't know how to do this on the Intel systems (never had to do it on mine), but I'm sure it's at Apple's online help pages.
     
  3. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
    #3
    Yup, linky.
     
  4. wawman macrumors newbie

    Joined:
    Dec 22, 2006
    #4
    Mag light out on mine.

    My magsafe light went out on my MacBook Pro too, but my battery is dead and it wont charge. So maybe it will maintain whatever charge the battery has.

    I can use the MBP if I have it plugged in, but sometimes the screen will go black and I have to shut it down and let it sit for awhile before I restart and then it will work fine.

    I have tried other chargers and another battery and reset the SMC, but it still does the same thing. I called AppleCare and they sent me a box to send it in, which I will send in tomorrow.

    Carlsen, what did you find out from AppleCare?
     
  5. Carlsen thread starter macrumors member

    Joined:
    Feb 20, 2007
    Location:
    Denmark
    #5
    I've tried resetting the SMC, without luck.

    Then I phoned up Apple. They are sending me a new charger and battery, will see if that works.
     
  6. iBorg20181 macrumors 6502

    iBorg20181

    Joined:
    Apr 5, 2006
    Location:
    Minneapolis, MN
    #6
    I had a similar problem with an iBook 4-5 years ago - ran on AC fine, but wouldn't charge battery. Apple ended up replacing the logic board, and all was well.
     
  7. wawman macrumors newbie

    Joined:
    Dec 22, 2006
    #7

    I hope that solves your problem, but I don't think it will. AppleCare wanted to send me a new charger and battery at first too, but then we checked a different charger and battery and we still had the same problem.
     
  8. Carlsen thread starter macrumors member

    Joined:
    Feb 20, 2007
    Location:
    Denmark
    #8
    Sadly, it was neither the charger or battery.

    It's been sent off for repair :(
     

Share This Page