Macbook Pro won't connect automatically WiFi

Discussion in 'MacBook Pro' started by ivoruest, Jun 1, 2012.

  1. macrumors 6502

    ivoruest

    Joined:
    Jul 12, 2010
    Location:
    Guatemala
    #1
    My Mac doesn't connect to my home Wifi automatically anymore. Do you know where o how do I manage to make it connect automatically again?? This began when I changed my Macs HDD (backup through Time Machine and then restore in the new one) but my old Mac was a Early 2008 Macbook Pro (non-unibody).
    Is there something that is causing this problem due to the change of hardware?
     
  2. macrumors 6502

    Joined:
    Dec 21, 2011
    #2
    Try System Preferences->Network->Advance->Preferred Network (highlight current home wifi-fi (Network Name) and delete (-).

    Now try to reconnect to your home wi-fi. Next, see if it connects automatically.
     
  3. thread starter macrumors 6502

    ivoruest

    Joined:
    Jul 12, 2010
    Location:
    Guatemala
    #3
    Thanks for the reply! It didn't work. I goess its because of the router configuration or something. I have a Belkin router set up as access point but any of the computers connect automatically now. I'll check this and see if I can fix it.
     
  4. macrumors demi-god

    Arelunde

    Joined:
    Jul 6, 2011
    Location:
    CA Central Coast
    #4
    You might have to reset your router (turn off, wait briefly, turn back on). If that doesn't help, push the "reset" button on it.

    I've had a lot of problems with my wifi printer (Canon MX870) dropping the connection. Spent hours toubleshooting and, as a last resort, reset the router. All better.
     
  5. macrumors newbie

    Joined:
    Jun 4, 2012
    #5
    Does the WiFi symbol have an "!" through it as mine did this a few months back and suddenly said that there was no hardware installed for the WiFi to be able to connect, all I did was leave it for a few hours or a day or 2 and it came back on, make sure you have not installed any virus' by mistake as this can happen easily and can affect things like this
     
  6. Peafreen, Aug 26, 2012
    Last edited: Aug 26, 2012

    macrumors newbie

    Joined:
    Mar 14, 2004
    Location:
    MA
    #6
    Wi-Fi Connection issue on older MacBook Pro w/Mountain Lion

    Having issues w/ turning on Wi-Fi on a MacBook Pro after installing Mountain Lion on an older machine. Everything was working fine until I turned it off and restarted the machine. It can't find any wireless network. Plus when I go into System Preferences It won't even turn it on. If I connect it to ethernet for a while then it seems to refix itself until the machine is shut down and turned on again. Everything else seems to be find, software running ok, etc. Any ideas? Tx.

    I'm using an Airport Extreme base station for wireless. I also just did the PRAM on start up, but thought I did that before as well. Is it an issue with Mountain Lion?
     

Share This Page