mach & mach.sym files in my dock

Discussion in 'macOS' started by mark88, Jan 14, 2006.

  1. mark88 macrumors 6502a

    Oct 30, 2004
    Ever since upgrading to tiger, mach & mach.sym files are visible in my dock. I always have my HD in the dock so I can access everything from there, but when right clicking on the icon these two files appear, whilst they did not in Panther.

    Is there any way to hide them?
  2. MisterMe macrumors G4


    Jul 17, 2002
    These files are not supposed to be visable and they are most certainly not supposed to appear in the Dock. I would bet dollars to donuts that these files are visable because you reinstalled your OS. You can drag them out of the dock. They should go "poof" and disappear in a puff of smoke.
  3. mark88 thread starter macrumors 6502a

    Oct 30, 2004
    No, I mean they're in a sub menu of the dock. ie, when I right click the HD icon in my dock, they appear in it context menu. Whereas they didn't before
  4. ToastyX macrumors regular

    Oct 4, 2005
    They are visible for me as well, but you can hide them by following these steps:

    1. Open TextEdit.
    2. Type in the following:


    3. Open the File menu and choose "Save As..."
    4. Type in the following: /.hidden
    5. A "Go To Folder" window will appear. Choose the "Go" button.
    6. Uncheck 'If no extension is provided, use ".txt".'
    7. Choose the "Save" button.
    8. A warning will appear. Choose the 'Use "."' button.

    The files should be hidden from the dock menu now.
  5. lexfuzo macrumors 6502

    Mar 15, 2005
    The heart of Europe
    You lost! :p
    I can reproduce that on my iBook which is on a clean install of Tiger.
    Bug or feature - to be honest, I don't bother.
    The trick with the .hidden file works, though.
  6. mark88 thread starter macrumors 6502a

    Oct 30, 2004
    I must be stupid, it doesn't seem to follow that route on my machine.

    As soon as I type "/" in the save as dialog, the goto window appears, if then I type "/.hidden" into that and then press go, it sends me back to the save as dialog in which it now says ".hidden.txt", I've followed your steps but the files still appear.
  7. ToastyX macrumors regular

    Oct 4, 2005
    I forgot that plain text is not the default. After you open TextEdit, open the Format menu and choose "Make Plain Text" if it's there. If you see "Make Rich Text" instead, you don't have to do anything there.

    As for saving, I don't know why it adds ".txt" for you, but change ".hidden.txt" to ".hidden" and try again.

Share This Page