Macintosh HD keeps on moving down in desktop

Discussion in 'macOS' started by steelfist, Sep 2, 2005.

  1. steelfist macrumors 6502a

    Joined:
    Aug 10, 2005
    #1
    the icon for Macintosh HD keeps moving down. i would like it nice and snug a the top right part of desktop as it should be, but everytime i restart or do some weird thing i don't know what it just moves downwards!

    the screenshot will show what my little HD icon likes to do. can anybody help me keep it locked at the top right corner?
     

    Attached Files:

  2. Mitthrawnuruodo Moderator emeritus

    Mitthrawnuruodo

    Joined:
    Mar 10, 2004
    Location:
    Bergen, Norway
    #2
    Not a problem: Just move away those folders that's blocking the place it should have been. :)

    Tip: Click somewhere on the Desktop, press cmd-J to get Desktop viewing options, and check the "Snap to Grid", then there should always be room enough around files, folders and disks on the Desktop.
     
  3. steelfist thread starter macrumors 6502a

    Joined:
    Aug 10, 2005
    #3
    ok. il try that. conveniently, though, i have a question. how do you make the margin between the icons a bit smaller? these icons take a bit of space IMO.
     
  4. Mitthrawnuruodo Moderator emeritus

    Mitthrawnuruodo

    Joined:
    Mar 10, 2004
    Location:
    Bergen, Norway
    #4
    You can set the size of the icons and/or the text labels in the same place as I mentioned above.

    The ability to set the space between the seems to have been hidden/removed (used to be able to set that to narrow, medium and wide somwhere, IIRC). :confused:
     
  5. zudo macrumors member

    Joined:
    Apr 7, 2005
    Location:
    UK
    #5
    Related question

    I hate the way all the mounted drive icons are so close to the right hand of the screen. I have my dock down the right hand side (works better for me on a widescreen like my pb 15") and the icons get a bit muddled with it.

    Does anyone know how to shift the icons left a bit?
     
  6. kalisphoenix macrumors 65816

    kalisphoenix

    Joined:
    Jul 26, 2005
    #6
    I'm willing to bet you're using a non-factory hard drive. See, Apple's strict qualilty control is not followed by the rest of the industry. Many other HD makers don't actually create a perfect vacuum in their hard drives!

    Why is this important?

    It's simple, Steelfist. As we all know, air has weight. Something containing a vacuum is necessarily lighter than it would be if it contained air. Thus, an Apple hard drive is slightly lighter than a generic hard drive.

    And, as we all know, OS X is a highly optimized operating system. It's like a Lamborghini. Everything is measured and counterbalanced to perfection. That slight amount of extra weight results in your "Macintosh HD" icon slipping down your screen.

    A common problem. See it on the forums all the time. Mac users have traditionally had problems using non-Apple hard drives and, uh, this is why. Vacuum. Performance operating system. Apple hard drives have just the right amount of suck, and as anyone knows, you can never have enough suck.

    Another possibility is that your hard drive is losing its vacuum. Possible even with Apple's stellar QC.
     
  7. Mitthrawnuruodo Moderator emeritus

    Mitthrawnuruodo

    Joined:
    Mar 10, 2004
    Location:
    Bergen, Norway
    #7
    The easiest way might be to change the Label positioning from bottom to right on the Desktop (again under cmd-J after clicking the Desktop). Some like that. Or you could play with the size of the icons and/or text labels to see if you find some setting you like.

    I, on the other hand, also like having the Dock on the right have dealt with it in another way: I just removed all "items" from the Desktop (in Finder preferences -> General). :)
     

Share This Page