MacMini boots windows by default now

Discussion in 'Windows, Linux & Others on the Mac' started by Dunepilot, Jun 21, 2006.

  1. Dunepilot macrumors 6502a

    Dunepilot

    Joined:
    Feb 25, 2002
    Location:
    UK
    #1
    Sorry if I'm duplicating someone else's thread here, but i haven't been able to find one.

    For some reason, since installing Boot Camp, every time I boot or restart my Macmini, unless I hold down alt it boots into Windows. Is there any way to stop this (and to make holding down the alt key a toggle between Mac OS and Windows)?
     
  2. TexBiker macrumors newbie

    Joined:
    Apr 28, 2006
    #2
    That's built-in to BootCamp. Windows becomes the default OS due to the methods that must be used to install the software.

    You can go into OS X and change the default if you wish.
     
  3. topgunn macrumors 65816

    topgunn

    Joined:
    Nov 5, 2004
    Location:
    Texas
    #3
    It is in the boot camp instructions. Go to the startup disk control panel in either Windows or OS X and select your Mac partition.
     
  4. Dunepilot thread starter macrumors 6502a

    Dunepilot

    Joined:
    Feb 25, 2002
    Location:
    UK
    #4
    Oh cool, thanks very much.

    Don't know why I didn't think to try that.
     
  5. mmulin macrumors 6502

    Joined:
    Jun 22, 2006
    #5
    actually on my imac setting the startup disk under the XP control panel doesn't do a damn (aka Beta software).. however doing the same in OS X works like a charm..
    just that you warned.
     
  6. Dunepilot thread starter macrumors 6502a

    Dunepilot

    Joined:
    Feb 25, 2002
    Location:
    UK
    #6
    I just tried this when I went home during my lunch hour, and nothing shows up under Startup Disk. It's just a grey dialogue box.

    Does anyone have any idea why I'd have a completely blank System Pref control panel?

    I guess I should repair permissions, but is this normal?
     
  7. mmulin macrumors 6502

    Joined:
    Jun 22, 2006
    #7
    you are saying even though during boot time, pressing ,Alt>, you get the choice, the OSX Startup Disk Pref Panel doesn't give you anything?

    In that case something is wrong. Try repairing permission but I doubt this will help as it is not fixing boot information..

    2nd question: are you using an administrative account when using macosx? if not, try to do so..
     
  8. Dunepilot thread starter macrumors 6502a

    Dunepilot

    Joined:
    Feb 25, 2002
    Location:
    UK
    #8
    Yes, that's right. Alt at boot gives the choice, Startup Disk pref doesn't. Will investigate this more tonight
     
  9. Mord macrumors G4

    Mord

    Joined:
    Aug 24, 2003
    Location:
    UK
    #9
    this is why i prefer the vista install method, unless you hold alt and select windows you wouldent know windows was their, (i hide the windows partition on my desktop.
     

Share This Page