MacMini G4 1,25 won't boot (again).

Discussion in 'PowerPC Macs' started by dutchchilly, Jul 5, 2010.

  1. macrumors member

    Jun 29, 2009
    Hi folks,

    I have a problem with my old G4 MacMini wich I use for my mp3's/torrents/webserver.

    I was ripping all my audio cd's, when all of a sudden my MacMini froze.
    After a reboot I heard a clicking noise coming from the HDD so my conclusion was: dead HDD.

    After ordering another 40GB ide HDD, I managed to install Tiger. Everything seem to work fine. But the moment I rebooted, I got this nice gray screen (again) with a logo flashing from a small finder icon to a question mark.

    Things I've tried:
    - I tried to reboot holding 'C', but that didn't work.
    - PRAM reset (holding down the power button when inserting the powercable, and pressing power again). Didn't work.
    - I've switched the 3V battery with an old PC motherboard battery (new one underway).

    Unfortunatly I don't have a wired Mac keyboard, so I don't have the 'CMD' button (Win keyboard). I do have a bluetooth keyboard, but I assume BT connection is only made when the OS has already started.
    (second hand Mac keyboard with wire is underway).

    Got any tips for me?
  2. macrumors 65816


    May 20, 2008
    Sounds like the partition table might be wrong. Did you select the "Apple" partition type?

    On the windows keyboard, the windows key should work in place of a command key.
  3. thread starter macrumors member

    Jun 29, 2009
    Yes I did, just like the old HDD wich have run perfectly for years.

    Too bad because I've allready tried that. It seems the MacMini won't react to keyboard input at all then....
    The 3 leds flash when booting, but capslock does not work after.
  4. thread starter macrumors member

    Jun 29, 2009
    Perhaps the battery I've changed is also dead (I don't have a multimeter)
    What are the signs of an empty battery?
  5. macrumors regular

    Apr 26, 2010
    Nanaimo, BC
    The installer might not have set your new drive as the default startup disk, so it might be worth attempting holding down the Option key when you turn it on and selecting the boot partition from the options that appear. Once into OS X, go into Startup Disk and make sure the new drive is the one selected.

    Just one more thing that hadn't been suggested, anyways. I suspect it's definitely software and not hardware related as the machine worked/booted fine when you installed OS X. Perhaps try booting again from the installer disc to see what it can see about your HD? Good luck!
  6. macrumors 68040


    Dec 7, 2009
    OP, have you jumpered your new HDD properly (to Master or simply like original drive was jumpered)?
  7. macrumors newbie

    Jun 8, 2010
    I had a problem with my G4 not working when the keyboard was plugged into a hub. I'm not sure about Bluetooth, though. The ? mark on the folder sounds like it's not picking up the OS on your HD. Try booting up and just letting it sit for awhile to see if it'll pick up the OS
  8. thread starter macrumors member

    Jun 29, 2009
    I've tried that, it doesn't seem to respond on the Option key (got a PC keyboard, with Mac signs on de Win keys), or any other key for that matter.
    I've literally pushed the CMD+Option+P+R (Resetting your Mac's PRAM and NVRAM) for 10 minutes. You should try that, holding the same 4 keys for 10 minutes, lot's of fun.

    I can't get it booted from the install disc anymore.
    It goes straight to the gray screen with the Apple logo, and then it just hangs. I don't hear any HDD activity anymore.

    Is it a problem if I try to testrun it with the topcase off?
  9. thread starter macrumors member

    Jun 29, 2009
    Yup just like the old one: no jumpers = Master.
  10. thread starter macrumors member

    Jun 29, 2009
    The keyboard goes straight in the MacMini.

    Yeah, I'm doing just that now. We'll see.

    Thanx for the effort guys, I really appreciate it!

    I've managed to get in Open Firmware (power on and hold the powerbutton after the signal, and after the chimes).
    From there I could boot from cd:

    boot cd:,\\:tbxi

    The gray screen with the Apple logo loads, I see the progress indicator, but then it hangs again.
    Booting to HDD in Open Firmware gives the Apple logo screen without a progress indicator, and then it hangs also.
    Can I do a hardware test in Open Firmware?

    Edit 2:
    I ran the extended hardware on partition 4 of the install disc with Open Firmware. All devices passed.
  11. macrumors 68040


    Dec 7, 2009
    Last what you can do is nvram reset with OF.
    BTW, with power button you've reset PMU not PRAM.
    What else...? Without Apple kbd not much more, i'm afraid.
    Your new HDD has identical jumpers setting as old one? I mean, that it could be different between manufacturers. Seagate could have different setup than Hitachi, for example. In one master will be no jumpers, in another no jumpers will be slave, like in 3.5" HDDs.
  12. thread starter macrumors member

    Jun 29, 2009
    Tried that, no results.

    Yes according to the jumper settings sticker, this should be right.

    The replacement HDD wasn't a new one, it could be a faulty one.....
    (although it passes the hardware test)

    Another thing, I tried the original HDD yesterday and from there I could boot straight to the install disc. Switched the HDD, tried to boot to the install disc again, hangs.
    It seems to be HDD related.
  13. thread starter macrumors member

    Jun 29, 2009
    Bought me a 60Gb HDD, installed it and it worked perfectly. :)

    So the replacement HDD was faulty. Ah well, at least I know a lot more of the ins and outs of MacOSX now ;)

Share This Page