MacPorts build on 10.5

Discussion in 'Mac Programming' started by Transeau, Oct 27, 2007.

  1. macrumors 6502a

    Transeau

    Joined:
    Jan 18, 2005
    Location:
    Alta Loma, CA
    #1
    Has anyone been able to build MacPorts on 10.5?
    It doesn't seem to like the X11 anymore.
    Code:
    Please install the X11 SDK packages from the
    Xcode Developer Tools CD
    configure: error: Broken X11 install. No X11 headers
    Please don't ask if I've installed X11 and the SDK. I'm not as dumb as I look.
     
  2. macrumors newbie

    Joined:
    Oct 28, 2007
    Location:
    Tokyo, Japan
    #2
    You should try following option for configure.

    . /configure LDFLAGS=-L/Developer/SDKs/MacOSX10.5.sdk/usr/X11/lib


    BTW, My Mac is cleanly installed Leopard on PowerBookG4.
    Please Let me know whether the scheme is succeeded or not on your MacPro.
     
  3. thread starter macrumors 6502a

    Transeau

    Joined:
    Jan 18, 2005
    Location:
    Alta Loma, CA
    #3
    Perfect! Just finished a clean build with gcc-4.2 on 10.5 (Mac Pro and Macbook Pro) Mini is next.
     

Share This Page