macro virus for MS Word 2004?

Discussion in 'Mac Basics and Help' started by maxterpiece, Sep 14, 2006.

  1. maxterpiece macrumors 6502a

    maxterpiece

    Joined:
    Mar 5, 2003
    #1
    Okay, I search and I search and I find all sorts of results for macro word viruses on mac os x. The only advice for getting rid of them that i've seen is to delete word prefs and infected files. I've tried this and it didn't work.

    The problem is pretty simple - I open any word file that i've created and it tells me there are macros and asks me if i wanna open it w/ macros, w/o macros, or not open it. I always choose to open it with macros disabled - the problem is I then get a read-only file, and when I want to save my changes I have to save the document under a new name. This is pretty annoying, because even after i resave the document under a different name, when i reopen it I have to go through the same thing.

    How do I make it stop?
     
  2. Jiddick ExRex macrumors 65816

    Jiddick ExRex

    Joined:
    May 14, 2006
    Location:
    Roskilde, DK
    #2
    You stop worrying and enable macros.
     
  3. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #3
    Yeah, I've been running round with other people's Office files for ages, macros-enabled, with no problems. Touch wood, you should be fine. :)
     
  4. maxterpiece thread starter macrumors 6502a

    maxterpiece

    Joined:
    Mar 5, 2003
    #4
    all the things i've read about these macro viruses say that as soon as you do that you let the thing do its evil business.

    And even if this macro thing is harmless, I'd still like to know why all my documents have magically acquired macros.
     
  5. loudguitars macrumors member

    Joined:
    Nov 3, 2004
    #5
    I'm actually having this exact same problem. I'm somewhat less concerned about viruses and more really, really irritated with having to click the little button all the time.

    What's weird is if I create a new document, then save it, then immediately try to close it, it asks me if I want to save changes. If I click no and then reopen it, it doesn't have macros. If I click yes and then reopen it, it suddenly does.

    I poked around the tools and organizer, but I can't even see any macros listed. What the hell is going on here, and how do I stop macros from randomly getting added to the document?
     
  6. MacBoobsPro macrumors 603

    MacBoobsPro

    Joined:
    Jan 10, 2006
    #6
    What the fish fart is a Macro anyway? Sorry to partly hijack (only a little tho) :D
     
  7. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #7

    There might be a Macro included in your Normal.dot file meaning all new documents have a Macro already in play. In the Tools menu of Word, go to Macro on any new document and make sure there is nothing listed. If there is, delete or remove it and save this new document as Normal.dot in your Templates folder.

    To do this, you'll need to opt to save tis as a template rather than a Word document and it should automatically take you to the right folder. It probably won't let you save it as Normal.dot in which case save it as Normal1.dot and then head back to the Templates folder once Word is closed and replace one with the other. :)



    Everything you want to know about Macros and their viruses. :)
     
  8. loudguitars macrumors member

    Joined:
    Nov 3, 2004
    #8
    This is where it gets weird. There are no macros listed in ANY of the documents I have when I go through the Tools > Macros menu, yet I keep getting the message saying I have macros anytime I open a document, and I keep getting prompted to save changes on things I just saved through the File > Save menu when I try to close them out. I'm very confused about this...
     
  9. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #9
    Do you know someone else with a Mac version of Office who doesn't have this problem? It might be worth trying to replace your Normal.dot file with theirs. Of course, this won't affect any current documents. :eek:
     
  10. jacklax macrumors newbie

    Joined:
    Sep 9, 2008
    #10
    I am having this same problem. When I try to send the file in gmail, I get a message warning me the file contains a virus and it will not send. Even if I make it a zip file or change the extension to .txt it does not send.

    where did these macros come from. i have no problem just keeping htem enabled if i could send the files though email.
    on office 2008 there are no more macros, and if the file contains them you can remove them instead of disable and the file will not be read only.

    is there a virus in those files or is it just the macros?
    how do i get rid of this?
     
  11. thelivingbarbie macrumors newbie

    Joined:
    Oct 24, 2008
    #11
    I cured my mac!

    I was having this exact same problem. No macros appeared when I checked. I went to the Normal.dot file and saw that it had been modified 2 days ago.

    I took the advice above and threw out all my recently created word docs and the old Normal.dot file, then emailed myself a clean Normal.dot file from another computer. When you get it, it appears as plain text but will open in word. Save as a template. Voila!

    I created a new test document, closed it and reopened--no macros. Then tested sending it through gmail.

    Thanks for the great advice!!:)
     

Share This Page