magic mouse bad lion issue

Discussion in 'Mac OS X 10.7 Lion' started by mesogreat, Feb 25, 2011.

  1. macrumors member

    #1
    I notice now that when you swipe back on a web page it goes to the widget page. So does that mean everytime you want to scroll back a page you have to hit the arrow now?:(
     
  2. macrumors 6502a

    Tomple

    #2
    Check your system preferences, this is most likely a configurable setting.
     
  3. macrumors 68040

    #3
    It's probably wise to explore the settings of a new OS before claiming it has bad issues.

    And if you do think there is a serious bug, surely you have filed a bug report like any good developer would, right?
     
  4. macrumors member

    #4
    Yeah thats what I thought. I looked in the mouse settings and it was pretty much what it was before. Maybe its something mozilla needs to update with the browser. Thats just a guess though.
     
  5. macrumors member

    #5
    Um... I wasn't claiming it as a bad issue. I was asking a question. Why sso angry :p
     
  6. macrumors 6502a

    iCheddar

    #6
    Swipe for backwards and forward seems to be missing system-wide. I just installed 10.7 on my Macbook Air and the feature is absent not only in third-party apps like Chome, but also shipping apps like Finder.

    It seems very odd to me to eliminate such a useful gesture, I don't give a damn if a 4 finger swipe can trigger mission control when 2 finger swipe no longer triggers back and forward.

    What's even more frustrating is that better touch tool doesn't have any gestures for two finger swiping that I could configure.
     
  7. macrumors 68040

    #7
    Sorry I was confused by the fact that the thread is titled "bad lion issue"
     
  8. mesogreat, Feb 26, 2011
    Last edited: Feb 26, 2011

    macrumors member

    #8
    nope wrong again... it said magic mouse bad lion issue. Meaning the issue is with the mouse. It's a no brainer that it's not a software error. I then clearly asked if anyone new of a setting to fix it. You seem to read into things way to easily. Did you even read the post? Or just the header.:eek:
     
  9. macrumors member

    #9
    Thanks for your post iCheddar. Glad to see im not alone with this issue. I would guess this will be fixed down the road.
     
  10. macrumors member

    #10
    I've been playing around a bit with Lion and just setup my magic mouse. What I've found, is that a single finger swipe left and right, will go forward and backward pages now. That is in Safari at least. I haven't installed any other browsers yet.
     
  11. macrumors member

    #11
    Did you do anything to make it be able to do that. Its true if you single swipe it doesn't go to the widgets. For me it doesn't do anything though.
     
  12. macrumors 603

    bedifferent

    #12
    In Safari, a SINGLE finger swipe left to right or vice versus brings you forwards/backwards in Safari.

    TWO finger swipes take you left or right on your desktop (you can be in any application and two finger swipes will still only apply to Finder). Swiping with two fingers to the right will invoke Dashboard (in iOS 4.X it would be the Spotlight page), or swiping left will bring you to any Spaces you have active.

    *In "System Preferences", in "Exposé", make certain "Show Dashboard as a space" is checked
     
  13. macrumors 6502

    #13
    Yep single finger works. I figured that out today

    I forget what's listed in preferences

    But double tap 2 fingers brings up mission control

    And double tap 1 finger in safari zooms on text like iOS
     
  14. macrumors member

    #14
    Very odd that everyones having success doing this and it's still a dead function for me. I thought since everyone was using mozilla and I was on chrome that it might be that. Nope its something else. I'm sure its a setting I need to stumble on.
     
  15. macrumors 6502

    #15
    Have you tried safari, just to check
     
  16. macrumors 68040

    cocky jeremy

    #16
    Are you using 3.6 or the 4 betas? I know what you mean about swiping spaces instead of swiping browser back/forth. Just setup for Magic Mouse with BTT and that'll fix it. Here's how i did it:

    Single finger swipe left - back in Safari
    Single finger swipe right - forward in Safari

    Double finger swipe left - left a Space
    Double finger swipe right - right a Space

    Fixed it for me.
     
  17. macrumors member

    #17
    It works with Safari. SO it is a mozilla chrome issue.
     
  18. macrumors newbie

    #18
    No. It's not a mozilla chrome issue.

    If you want magic mouse 2 fingers scrolling for other browsers/apps back, do follows:(you need to give up something)

    1.Open Magic Mouse setting in System Preferences
    2.In More Gestures tap, click the drop down list under Swipe between pages and choose Swipe left or right with two fingers
    3.Uncheck the Swipe between full-screen apps

    Now you get your old 2 fingers gesture for magic mouse back, and you give up smooth moving backward/forward in Safari -- you can still move backward/forward in Safari, just not smoothly.

    I wrote detail in blog: http://tkjune.com/2011/07/05/using-magic-mouse-2-fingers-swipe-in-chrome-firefox-in-lion/
     
  19. macrumors newbie

    #19
    I am sorry but this is not working for me!
    I mean, ok you get back your 2-figer swiping for Back and Forward and that's great!
    But then you don't get any gesture for Space switching. I knew you didn't have it beforehand since this is a new feature, but missing a new feature right after the installation of the OS is a bit harsh :(
     
  20. macrumors newbie

    #20
    You do not need to disable anything. instead of using two fingers, use one.

    i.e. push your finger to the right o go back and pull it to the left to go forward, if you are right handed.
     
  21. macrumors newbie

    #21
    The solution to your problem…*i think.

    (I have swedish OS so I apologize if the translations below are a little wrong, but I think you will find your way anyway).

    Go to "More gestures"
    For "Swipe between pages" choose the third option "Swipe with two or three finger".

    With that option you will have both the new and the old behavior.

    /Andreas
     
  22. macrumors newbie

    #22
    This backward/forward thing does not work on Chrome!
    So I have to use the 2-finger swipe.
    But this way I lose the 2-finger swipe to switch spaces!
     
  23. macrumors newbie

    #23
    Chrome issues

    thank you for your help on this issue. I am happy now that I've worked out how to resume using my 2 finger swipe in Chrome, it's a sacrifice I'm willing to make.:D
     
  24. macrumors 6502

    marsmissions

    #24
    As others have said, you're using the two finger swipe and on the mouse that moves your space, not your page. Firefox and Chrome do not yet support the ONE FINGER swipe of the magic mouse or the TWO FINGER swipe of the track pad..


    But like others have said, this is a bad mesogreat issue.
     
  25. macrumors newbie

    #25
    For the space switching, I'm using 3 fingers on magic mouse or 4 fingers on trackpad. I don't want to miss it either. In another hand, my magic mouse ran out of power often and a little bit low for me. In the end I take back my Logitech MX518, which has 8 buttons. When I go out, I would take magic mouse with me.
     

Share This Page