Mail 6.0 HTML signature solved

Discussion in 'OS X Mountain Lion (10.8)' started by jeremymarlowe, Jul 28, 2012.

  1. jeremymarlowe, Jul 28, 2012
    Last edited: Jul 28, 2012

    macrumors newbie

    Joined:
    Jul 28, 2012
    #1
    Finally figured out how to transfer my .webarchive HTML signature from Lion to the new .mailsignature file in Mountain Lion. This will work, assuming you already have your HTML signature source code:

    1. Open Mail
    a. Go to Preferences > Signatures
    b. Create a new signature (no need to customize it here)
    c. Quit Mail

    2. Open Finder
    a. Go > Go To Folder
    b. Go to the folder: ~/Library/Mail/V2/MailData/Signatures/

    3. Select your .mailsignature file
    a. Secondary (right) click
    b. Open With > Other
    c. Open with TextEdit
    d. You will see a few lines of metadata followed by a standard signature code:

    Code:
    Content-Transfer-Encoding: 7bit
    Content-Type: text/html;
    	charset=us-ascii
    Message-Id: <30069E24-B7CD-4BE7-A550-46CD6E3979F3>
    Mime-Version: 1.0 (Mac OS X Mail 6.0 \(1485\))
    
    <body style="color: rgb(0, 0, 0); font-family: Helvetica; font-size: medium; font-style: normal; font-variant: normal; font-weight: normal; letter-spacing: normal; line-height: normal; orphans: 2; text-align: -webkit-auto; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-size-adjust: auto; -webkit-text-stroke-width: 0px; word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; "><div>Jeremy Marlowe</div><div>jeremymarlowe@me.com</div><div><br></div></body><br class="Apple-interchange-newline">
    4. In a new TextEdit file, open your HTML signature source code
    a. Copy your entire code *EXCEPT* for any <html> and <body> tags at the beginning and end of your code
    b. Again, DO NOT COPY <html> and <body> tags at the beginning and end of your code

    5. Go back to the .mailsignature code open in TextEdit
    a. Replace the standard signature code below the metadata with your copied source code (DO NOT EDIT OR REMOVE THE METADATA)
    b. Save
    c. Close

    6. Navigate back to the .mailsignature file you just edited in the ~/Library/Mail/V2/MailData/Signatures/ folder
    a. Secondary (right) click > Get Info (or command+i)
    b. Check the "Locked" checkbox (under General)**
    ** This is CRUCIAL. If you don't lock it, Mail will overwrite your file.

    7. Restart Mail
    a. Go to Preferences > Signatures
    b. You should see your HTML signature (just like Lion's Mail, images will not display here, but they will show up when you compose your email - assuming, of course, that your image source is still valid)

    8. Compose an email and apply the signature to test!

    I hope this helps!

    If it doesn't work, the likely causes are that you copied and pasted your code incorrectly or did not lock the .mailsignature file after editing. Be very careful with steps 4, 5 and 6 or this won't work.
     
  2. macrumors 68040

    cocky jeremy

    Joined:
    Jul 12, 2008
    Location:
    Huntington, WV
    #2
    Another, and probably easier, yet more expensive route, is to buy SignatureProfiler. I've had it for a year or so now and love it. It was just updated to work with Mountain Lion, too.
     
  3. macrumors newbie

    Joined:
    Jun 19, 2007
    #3
    Jeremy, you're so cocky! :p

    hey thanks for the tip! Will check that out. And if it doesn't work out, will check out SignatureProfiler. Hoping that does not insert images, etc as "attachments" which is why I do the hack...
     
  4. Macficionados, Aug 9, 2012
    Last edited: Aug 9, 2012

    macrumors newbie

    Joined:
    Aug 9, 2012
    #4
    Brilliant fix

    Thank you for your tut. I would just add for newbies like me that you have to keep the metadata plus one <div>[your customized content in html]</div> to have it work properly.

    In green what you keep from the .mailsignature file, in red the content you want to see as a signature.

    Content-Transfer-Encoding: 7bit
    Content-Type: text/html;
    charset=us-ascii
    Message-Id: <31CFBA1C-3272-4FC2-B15F-89B5A2F46001@home>
    Mime-Version: 1.0 (Mac OS X Mail 6.0 \(1485\))

    <body style="color: rgb(0, 0, 0); font-family: Arial; font-size: medium; font-style: normal; font-variant: normal; font-weight: normal; letter-spacing: normal; line-height: normal; orphans: 2; text-align: -webkit-auto; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-size-adjust: auto; -webkit-text-stroke-width: 0px; word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; ">
    <div>

    [here your customized content in html]

    </div>
    </body>
    <br class="Apple-interchange-newline">
     
  5. macrumors newbie

    Joined:
    Sep 7, 2008
    #5
  6. macrumors newbie

    Joined:
    Aug 29, 2008
    Location:
    Arizona
    #6
    Another Option

    Hi,
    Another option is a little app called Attachment Tamer. I purchased it back when snow leopard came out. It wasn't very much and it has consistently updated my mail behavior with each change by apple.
    Saw that my logos were gone from my email after Lion upgrade.
    I updated Attachment Tamer and it solved the problem.
     
  7. macrumors newbie

    Joined:
    Sep 3, 2012
    #7
    Is anyone having an issue where doing this process on one device trashes the Signature on another?

    I believe every time you try this method, Mail is attempting to sync the signature across to alternate devices. It doesn't seem to be a huge fan of the locked file and is unable to send it.

    Trying to fix the signature on the alternate device through the same process renders the main device's signature unusable as well.

    Shame they had to change how it worked.
     
  8. macrumors newbie

    Joined:
    Sep 7, 2008
    #8
    Have you tried setting up 2 different signatures, but with identical content?
     
  9. macrumors newbie

    Joined:
    Dec 29, 2010
    #9

    You don't actually need to lock the file. The reason it is being overwritten is because you are syncing with iCloud and the iCloud version is replacing the one you are modifying. If you go to "~/Library/Mobile Documents/com~apple~mail/Data/MailData/Signatures/" you will see the mail signature file there. If you make your changes there, then it will automatically change the signature on all your computers. And you won't have the problem of syncing your signature.
     
  10. macrumors newbie

    Joined:
    Jul 5, 2014
    #10
    html head and body tags

    Not sure why it is being said not to use html head and body tags.

    My original webarchive signatures were automatically converted to mailsignature ones on the upgrade. On checking them it is clear that all tags remained in tact which includes doctype declaration, html, head and body tags. And this causes no problem in the appearance of the signatures.

    I have since created two new ones using doctype, html, head and body tags without problem. Just copy pasting over the default mailsignature <body class ...> section.

    So long as you completely replace the mailsignature body tag, it works perfectly well. You don't need the line break at the end either.
     

Share This Page