Mail and iMessage pop up on start up?

Discussion in 'OS X Mountain Lion (10.8)' started by GonzagaDynasty, May 12, 2013.

  1. GonzagaDynasty
    Expand Collapse
    macrumors regular

    Joined:
    Nov 30, 2009
    #1
    So every day when I turn my MacBook Pro on, and sign in to my account, iMessage and mail automatically pop up, and I am tired of it... I don't want them to pop up unless I click them, because I rarely use iMessage, and I don't want my personal emails just randomly popping up when I first sign on.

    Can someone tell me how to change this? Thank you!
     
  2. benwiggy
    Expand Collapse
    macrumors 68020

    Joined:
    Jun 15, 2012
    #2
    There are two issues here:

    1. System Preferences > Users & Groups > Login Items has a list of apps that will open when you log in. Make sure they are not in that list.

    2. OS X has a feature called "Resume". Any apps open when you shutdown/log out will be launched when you next restart. So if they were open when you shutdown, they will be relaunched.

    Assuming that those apps are not in the Login Items list and they were not open when you shutdown, they should not launch when you restart.

    If they are still launching, then something else is at work and we will nee to delve deeper.
     
  3. GonzagaDynasty
    Expand Collapse
    thread starter macrumors regular

    Joined:
    Nov 30, 2009
    #3
    They are not in the log in items...

    Yeah they open every single time I turn the computer on, and I never use either... I always "quit imessage/mail" and they still come back next time I log on.
     
  4. Serban
    Expand Collapse
    macrumors 601

    Joined:
    Jan 8, 2013
  5. dontpannic
    Expand Collapse
    macrumors 6502

    dontpannic

    Joined:
    May 16, 2011
    Location:
    Orpington, Kent, UK
    #5
    Right click on dock icons, options, untick open at login.
     

Share This Page