Mail.app sound effect thru SoundSticks

Discussion in 'Mac Apps and Mac App Store' started by geeman, Dec 9, 2003.

  1. geeman macrumors regular

    Joined:
    Nov 27, 2001
    Location:
    At My Mac
    #1
    Whenever I get a new mail, I've set the preferences of Mail.app to play a sound (the one that's called, imaginatively enough "new mail sound").

    Whenever I send a mail, Mail.app plays a nice "swoosh" sound, confirming that the mail has gone.

    Now to my problem: While the "swoosh" comes through loud and clear from my SoundSticks, the "new mail sound" only comes through the internal speakers of my 1Ghz PB. I'm running Panther v.10.3.1.

    This can be a real pain sometimes, as I have little aural indication of having received a mail when I'm not in front of my Mac. I've tried the usual rebulding permissions/clearing caches/deleting preferences stuff, but still haven't had any luck.

    Anyone else have the same problem, or have any other ideas as to what I could try?


    Cheers,
     
  2. Counterfit macrumors G3

    Counterfit

    Joined:
    Aug 20, 2003
    Location:
    sitting on your shoulder
  3. bousozoku Moderator emeritus

    Joined:
    Jun 25, 2002
    Location:
    Gone but not forgotten.
    #3
    Could it be that the Sound preferences are set to different output? Since I've had an external audio processor, I've found that there are separate outputs for Sound Effects and Output.

    It may be that mail is using different categories of sound to impress you.
     

    Attached Files:

  4. geeman thread starter macrumors regular

    Joined:
    Nov 27, 2001
    Location:
    At My Mac
    #4
    Nope - but good thinking. I have both "output" and "alerts" set to output through the SoundSticks.

    BTW: If I manually try to get mail (and there isn't any) then the "No mail" sound comes through the SoundSticks as well (??)

    Weird, huh?

    [edit]: Get this: when you select a sound in the preferences of Mail.app, you get a 'preview' of the sound, right? Well, when I go through the selection of mail sounds, they all 'preview' correctly - i.e. through the SoundSticks!
     
  5. Counterfit macrumors G3

    Counterfit

    Joined:
    Aug 20, 2003
    Location:
    sitting on your shoulder
    #5
    Get Pacifist off of VersionTracker and try reinstalling Mail. That could possibly fix your problem. Did you try trashing the preferences?
     
  6. geeman thread starter macrumors regular

    Joined:
    Nov 27, 2001
    Location:
    At My Mac
  7. Counterfit macrumors G3

    Counterfit

    Joined:
    Aug 20, 2003
    Location:
    sitting on your shoulder
    #7
    Erm, how did you fix it, if you don't mind sharing?
     
  8. Powerbook G5 macrumors 68040

    Powerbook G5

    Joined:
    Jun 23, 2003
    Location:
    St Augustine, FL
    #8
    While on the subject, I've noticed that when you click on "Get Mail", the sound effect sounds very surround soundish on my PowerBook's speakers. Everytime I click on it, I end up looking around to the right thinking I heard something in the corner of the room.
     
  9. geeman thread starter macrumors regular

    Joined:
    Nov 27, 2001
    Location:
    At My Mac
    #9
    Sorry - should've put everyone out of their misery ;-)

    I was about to run Pacifist so that I could re-install just Mail.app, but then found out that there were a couple of 'custom' sounds that had found their way into ~/Library/Sounds. As you know, you can import custom sounds from the Preferences in Mail. Note that these addtional sounds weren't actually selected for use, they were just sitting there in the list.

    As a last resort before deleting and re-installing Mail, I removed them from the list. No change. Then I removed them from the Sounds folder - success!

    Weird. All the other mail notification sounds worked fine, just the "Mail Received" one - and even that worked OK, just not through the SoundSticks!

    Anyway, I'm a happy bunny again,

    Thanks again for everyone's help!
     

Share This Page