Mail auto-deleting messages?!

Discussion in 'Mac Apps and Mac App Store' started by macmama, Nov 26, 2006.

  1. macmama macrumors regular

    macmama

    Joined:
    Nov 26, 2006
    Location:
    New Jersey
    #1
    Hi friends,

    I've had a mostly-smooth transition from my second gen iMac to a sparkly new MacBook, save for one thing: Mail is nuking messages in my inbox after a week. Gah! I need those!

    One might think that these settings would be in Preferences>Mailbox Behaviors, but I'm at a loss. Virtual baked goods and eternal gratitude to anyone who can help.

    TIA,
    Lisa
     
  2. JAT macrumors 603

    Joined:
    Dec 31, 2001
    Location:
    Mpls, MN
    #2
    In Prefs:Accounts:Mailbox Behaviors are deletion settings for me. This is with the latest version of Mail, 2.1.1.

    Are yours just not there at all?
     
  3. JAT macrumors 603

    Joined:
    Dec 31, 2001
    Location:
    Mpls, MN
    #3
    Wait a sec, I see you mean from Inbox. What server do you use? Perhaps it has settings separate from Mail. I had to adjust Gmail online a couple times to get everything working the way I want it with Mail.
     
  4. macmama thread starter macrumors regular

    macmama

    Joined:
    Nov 26, 2006
    Location:
    New Jersey
    #4
    Hi JAT,

    It's mac.com mail. I know there are settings on webmail for how frequently to delete mail, but on my old iMac, the messages stayed in the application Mail until I tossed them, even if they were long gone from webmail. I would usually start purging through them when it got up to 400 messages or so, but I can't get more than a week's worth of mail accrued now on the new Book...
     
  5. JAT macrumors 603

    Joined:
    Dec 31, 2001
    Location:
    Mpls, MN
    #5
    Well, I'm stumped. If you've checked all the server settings, Mail settings and Rules, maybe deleting Mail prefs would fix it.
     
  6. macmama thread starter macrumors regular

    macmama

    Joined:
    Nov 26, 2006
    Location:
    New Jersey
    #6
    Thanks, JAT. Here's a pic of my mailbox behaviors in Preferences. Don't see anything about deleting messages in the Inbox... just from the trash, sent, etc.
     
  7. WildCowboy Administrator/Editor

    WildCowboy

    Staff Member

    Joined:
    Jan 20, 2005
    #7
    Interesting...I'm stumped too. Can you also post a screenshot of the "Advanced" pane there?
     
  8. macmama thread starter macrumors regular

    macmama

    Joined:
    Nov 26, 2006
    Location:
    New Jersey
    #8
    Sure, here you go.
     
  9. macmama thread starter macrumors regular

    macmama

    Joined:
    Nov 26, 2006
    Location:
    New Jersey
    #9
    Okay, so to rephrase: are there any controls where you can set your inbox to automatically delete mail after a certain period of time (since I want to set that to "never")? Thanks!
     
  10. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #10
    .Mac accounts are IMAP-based, meaning they synchronise with the server and can be modified from any internet-enabled computer. Do you have another machine that is accessing this same email account? :)
     
  11. macmama thread starter macrumors regular

    macmama

    Joined:
    Nov 26, 2006
    Location:
    New Jersey
    #11
    Indeed I do, Mad Jew. At the risk of sounding thick, what do you suggest I try? The desktop that's also gathering my mail is keeping all the messages indefinately, while the macbook is purging them after a week...

    THANKS!!
     
  12. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #12
    Well, check that the desktop is leaving the messages on the server. Your desktop may be downloading the emails to a local folder (on your desktop) and then taking them off the server which will then sync with .Mac and remove them from your MacBook too. Can we assume the desktop is a Mac running Mail? Maybe show us some of its settings. :)
     
  13. macmama thread starter macrumors regular

    macmama

    Joined:
    Nov 26, 2006
    Location:
    New Jersey
    #13
    Hey Mad Jew... I went to the old iMac and changed mail's settings to not erase messages from the server after a week. I'm still running Mail 1.3.11 on that machine, so the preferences looked really different. Thanks for the tip; I'm keeping my fingers crossed! :D
     
  14. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #14
    I reckon that coulda been your problem. Fingers crossed. :D
     

Share This Page