Mail driving me nuts!!!!!

Discussion in 'Mac Apps and Mac App Store' started by sers, Nov 13, 2006.

  1. sers macrumors regular

    Joined:
    Jan 11, 2006
    #1
    Mail keeps asking me for my "Keychain" password. It's driving me freakin' bananas!!!!

    I did a search and tried some of the tips I found, but none seem to work. I even used the help feature, to no avail.

    Has anyone had any luck in getting rid of this problem? Somethings wrong if the bloody thing can't even remember a password!!!

    Otherwise I absolutely LOVE my iMac G5.:D
     
  2. ChickenSwartz macrumors 6502a

    Joined:
    Jul 27, 2006
    #2
    Is it asking you for your password for your e-mail account? Even though you have saved it in you keychain? This was happening to me earlier, I had to enter it 3 times before it worked, kind of annoying.
     
  3. gr8tfly macrumors 603

    gr8tfly

    Joined:
    Oct 29, 2006
    Location:
    ~119W 34N
    #3
    Try deleting the Key using Keychain Access (in Utilites folder). I've had the same thing happen, tho not in a while. Usually, deleting the Key and letting Mail create a new one fixes it.

    Quit Mail, before you delete the Key.
     
  4. njmac macrumors 68000

    njmac

    Joined:
    Jan 6, 2004
    #4
    Same thing keeps happening to me too. I actually quit mail the other day because it was so annoying.


    Thanks, I'm giving this a try :)

    Another weird thing, EVERY time iTunes starts, I have to accept the terms and conditions again. Very annoying. :mad:
     
  5. gr8tfly macrumors 603

    gr8tfly

    Joined:
    Oct 29, 2006
    Location:
    ~119W 34N
    #5
    Try Repair Permissions (Disk Utility, in Utilities folder). Actually, it would be good to run that before deleting/creating the new Key(s).
     
  6. ero87 macrumors 65816

    ero87

    Joined:
    Jan 17, 2006
    Location:
    New York City
    #6
    i find this sometimes happens when the email service you're connecting to is down. not really mail's fault...
     
  7. sers thread starter macrumors regular

    Joined:
    Jan 11, 2006
    #7
    The password is in the "login" keychain. That does particular keychain have to be locked? It is currently unlocked.
     
  8. WildCowboy Administrator/Editor

    WildCowboy

    Staff Member

    Joined:
    Jan 20, 2005
    #8
    No, it should be unlocked. As ero87 mentioned, I also get this when the e-mail provider is down. I have a Yahoo! Small Business e-mail account that frequently does for a few minutes at a time. Could that be the case here?
     
  9. gr8tfly macrumors 603

    gr8tfly

    Joined:
    Oct 29, 2006
    Location:
    ~119W 34N
    #9
    That seems to trigger the Key corruption, but once it's happened (corrupt Key), doesn't seem to matter if the server's up or down. Just my observation over time. Haven't seen this happen in quite a while, though, and as far as I can tell my server's behavior hasn't changed. (running Apple Mail Service, 10.2 Server)
     
  10. DeSnousa macrumors 68000

    DeSnousa

    Joined:
    Jan 20, 2005
    Location:
    Brisbane, Australia
    #10
    I get this all the time also, drives me nuts. Never been able to resolve it :eek: :(
     

Share This Page