Mail - too many e-mails downloaded

Discussion in 'iPhone Tips, Help and Troubleshooting' started by jsnop, Jun 29, 2007.

  1. macrumors newbie

    Joined:
    Jun 27, 2006
    #1
    Loving my new iPhone, but the mail app downloaded all my e-mails on the servers - I was wondering if there is an easy way to delete all these e-mails in one swoop.

    (As long as I'm asking, is there a way to manually add music to the iPhone?)
     
  2. macrumors G4

    Teh Don Ditty

    Joined:
    Jan 15, 2007
    Location:
    Maryland
    #2
    Disable autosync.
     
  3. macrumors regular

    Joined:
    Oct 24, 2005
    #3
    using gmail? under "settings" you have to activate to only download new emails.
     
  4. thread starter macrumors newbie

    Joined:
    Jun 27, 2006
    #4
    it's my e-mail settings copied from Mail on my mac
     
  5. macrumors 6502a

    Joined:
    Mar 25, 2006
    Location:
    Central Coast, California
    #5
    I too am having a little problem where I have my Gmail setup for POP only to allow new messages downloaded from now on, and yet my iPhone will constantly populate with 25 messages... When I start deleting them off the phone, more come in until it reaches 25.

    How can I not have any of my old emails come through to my phone? Tips anyone?

    Thanks. :)

    PS - This device is still really impressing me!!! :D
     
  6. macrumors regular

    Joined:
    Jun 26, 2007
    #6
    Disable recent mode on the iPhone. In this mode (advanced settings for the account) it will always try to pull in 25 (or 50, 100, etc) of your recent emails.
     
  7. macrumors 6502a

    Joined:
    Mar 25, 2006
    Location:
    Central Coast, California
    #7
    Oh awesome, thank you! :)
     
  8. macrumors newbie

    Joined:
    Jun 29, 2007
    #8
    I'd like to know how to delete ALL emails in an iPhone in-box...
     
  9. macrumors newbie

    Joined:
    Apr 23, 2003
    Location:
    California
    #9
    too much email

    I had this problem too, I actually had to remove a ton of email that was on my web server. I'm still looking into why my pop mail account isn't removing it but once I got it off the server my iphone mail started working properly.

    I believe you have to delete all your mail one by one however you can either hit edit, then start hitting the red "no" sign then delete or you can slide your finger across an email to delete it.
     
  10. macrumors regular

    Joined:
    Jun 17, 2007
    #10
    I turned Use Recent Mode off on both of my gmail accounts, and as I'm going through deleting my e-mails, it keeps pulling more in until it's at 25... what's the deal?
     
  11. macrumors regular

    Joined:
    May 19, 2007
    Location:
    Maryland, U.S.A
    #11
    OK dumb question, but how do you get to the Advanced settings?
    I thought I got to it before, but can't, for the life of me, find it now.

    Thanks.
     
  12. macrumors 65816

    Photography

    Joined:
    Apr 10, 2007
    #12
    Settings > Mail > Email Accounts - select email account > Advanced

    coolosxapps
     
  13. macrumors regular

    Joined:
    May 19, 2007
    Location:
    Maryland, U.S.A
    #13
    Thanks, coolosxapps.
     
  14. macrumors 65816

    Photography

    Joined:
    Apr 10, 2007
    #14
    No problem, iMichael72.

    Thanks for that helpful tip, chriswheat.

    coolosxapps
     
  15. macrumors regular

    Joined:
    May 19, 2007
    Location:
    Maryland, U.S.A
    #15
    Found Advanced, can't find Recent!

    OK, something isn't right here. I found the Advanced setting, but don't see anything listed as Recent Mode.
     
  16. macrumors regular

    Joined:
    May 23, 2007
    #16
    Well, this probably isn't exactly what you want, but you can delete the account, and then recreate it. All your emails in your inbox are gone (but it may try to download them again).
     
  17. macrumors member

    Joined:
    Jun 20, 2007
    #17
    Same here - I believe I am in the correct place too. Help!
     
  18. macrumors regular

    Joined:
    Nov 8, 2006
    #18
    Ditto.
     
  19. macrumors regular

    Joined:
    May 23, 2007
    #19
    Just to clarify, I meant delete the account on the iPhone.
     
  20. macrumors 65816

    Photography

    Joined:
    Apr 10, 2007
    #20
    Y'all are using Gmail accounts when doing this, right?

    I believe this feature only applies to Gmail accounts, as earlier I was setting up AOL Mail on a friend's iPhone and I couldn't find the option under the Advanced menu to disable recent mail.

    So if you can't see it, that may be the problem - that this feature may be Gmail-specific.

    coolosxapps
     
  21. macrumors 68000

    technicolor

    Joined:
    Dec 21, 2005
    Location:
    ><><><><
    #21
    Gmail is truly a mess on the iPhone . I've tried all the solutions listed in the various posts, and nothing seems to work. I've gone as far as archiving all the email in my inbox, there are zero emails on inbox and some how my phone still manages to pull old emails from somewhere.
     
  22. macrumors regular

    Joined:
    May 19, 2007
    Location:
    Maryland, U.S.A
    #22
    OK, no, I'm using Comcast (POP) thanks.

    I thought I was losing it there for a second!
     
  23. macrumors member

    Joined:
    Jun 20, 2007
    #23
    I too am using comcast - I too am glad I am not alone - thought I was going to scream.
     
  24. macrumors 68020

    freeny

    Joined:
    Sep 27, 2005
    Location:
    Location: Location:
    #24
    This thread was very helpful. Now if they would just fix the "inbox" & "sent" mail all being in my inbox ill be happy.
     
  25. macrumors 68000

    technicolor

    Joined:
    Dec 21, 2005
    Location:
    ><><><><
    #25
    Oh is that what all that crap is that keeps popping up in my inbox even though it is empty?

    ARGH
     

Share This Page