MAJOR screen issues with my 27" iMac

Discussion in 'Mac Basics and Help' started by The.316, Jan 9, 2013.

  1. The.316
    Expand Collapse
    macrumors 65816

    The.316

    Joined:
    Jul 14, 2010
    Location:
    25100 GR
    #1
    I have a 27" mid 2010 iMac, with a SSD in the optical drive. The last few days, I have been getting freezes on the screen. I could hear the background sound and see the mouse cursor move, but the screen would be frozen and I couldnt do anything except for restart. Just a little while ago, I get this:

    [​IMG]

    and this happens:

    Video

    I dont know what to do now. I did a PRAM reset just to do it, but Im still getting the same problem. Worse case scenario, I send it in since I have 4 months left on my applecare, but Im wondering if anyone has any suggestions first.
     
  2. justperry
    Expand Collapse
    macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
  3. The.316
    Expand Collapse
    thread starter macrumors 65816

    The.316

    Joined:
    Jul 14, 2010
    Location:
    25100 GR
    #3
    Thanks. I was looking for that earlier, but I forgot what it was called. Im glad I have the applecare though, because if I do have to send it away, they will probably replace my screen too because its got the yellow and dark spots all over.
     
  4. The.316, Jan 9, 2013
    Last edited: Jan 9, 2013

    The.316
    Expand Collapse
    thread starter macrumors 65816

    The.316

    Joined:
    Jul 14, 2010
    Location:
    25100 GR
    #4
    Ran the hardware test, and it said that there were no issues. I am back from safe mode, and its back to normal. Anything else I can do? I think Im still going to send it away to get looked at.

    Edit: I logged in as a guest on my iMac, and now Im not getting any problems whatsoever. Why would this be going on only when Im signed in?
     
  5. The.316
    Expand Collapse
    thread starter macrumors 65816

    The.316

    Joined:
    Jul 14, 2010
    Location:
    25100 GR
    #5
    Anyone have any ideas? I left my iMac off all night, and just turned it on this afternoon. Its working fine so far, but Im sure that its going to start bugging out again. I just find it weird that when I logged in as a guest user, I didnt seem to have any problem, but as soon as I logged out, and in to my account, it froze immediately.
     

Share This Page