Making a default wireless connection?

Discussion in 'Mac Basics and Help' started by Danyell, Nov 4, 2007.

  1. macrumors newbie

    Oct 1, 2006
    I just set up a new secure wireless network at my new apartment. But even though I saved the password onto my computer, I still have to manually select my network every time I try to log on. And even then Airport sometimes says it "cannot locate any of your trusted networks" and suggests another local connection, or says there is an error connecting.

    Is there anyway to choose my network as my primary so it will always try to connect when I log on? My brother had set up our connection when I lived at home and it always automatically connected with no problem. Any suggestions?

    Thanks! :D
  2. Retired


    May 16, 2006
    Apple in the top left -> Location , make the network you're on Automatic :)
  3. Administrator emeritus


    Jan 15, 2006
    The Kop
    Are you using Leopard? If so sounds like the bug many of us are having which usually sorts itself out if you turn airport on and off a couple of times.

    Anyway to do what you asked in Leopard

    System Preferences - Network - Airport - Advanced - +

    Can't fully remember how in Tiger but should be along the same lines.


    Doesn't location only appear if you have setup multiple locations. For example i don't have that menu s i only have one setup being a desktop.

    Edit 2: Case in point, First shot with only one location, the second with multiple locations

    Picture 1.png Picture 2.png
  4. Moderator emeritus


    Jan 9, 2004
    Grand Rapids, MI, USA
    In Tiger I always have the Location menu, but with just the "Automatic" item in it, including on my desktop iMac, which has only one location / one network. I'm not clear that this will actually help much though. I really never used this feature, even on my notebook which was set to only connect to one of about five networks I authorized (i.e. one here, two at the University, one at another one of our hospitals, and one at Camp -- always on "Automatic" location). Sometimes, though, deleting the existing location and making a new one solves cryptic problems.


    In Tiger, you go to Sys Prefs -> Network -> Airport, and make sure that it's set up to join preferred networks by default (pulldown at the top). Then, you can click Options and define behavior when no preferred network is available (by default, it prompts you; my Macs are set to keep searching for preferred networks and not to join other networks unless I initiate it) and also whether or not newly joined networks automatically become preferred. This should already have been set up so that they do, though.

Share This Page