Mamp and my Site go to the wrong place on /manual

Discussion in 'Web Design and Development' started by Cabbit, Jan 2, 2010.

  1. macrumors 68020

    Cabbit

    Joined:
    Jan 30, 2006
    Location:
    Scotland
    #1
    When i try to get my framework to link to the manual controller of my site on ether my localhost or host.

    So when i go to http://localhost:8888/manual/ it instead of loading up my manual controller it opens up the a 404 error outside my framework, and the apache manual on my hosting for some reason.
    Is it possible to change my .htaccess to stop this from happening i had though that all links were successfully redirected to index.php

    .htaccess
    Code:
    RewriteEngine On
    RewriteRule ^(.*)$ public/index.php?rt=$1 [PT,L]
    
    /public/.htaccess
    Code:
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    
    RewriteEngine On
    RewriteRule ^(.*)$ index.php?rt=$1 [PT,L]
    RewriteRule ^(.*)$/$ index.php?rt=$1 [PT,L]
    
     
  2. thread starter macrumors 68020

    Cabbit

    Joined:
    Jan 30, 2006
    Location:
    Scotland
    #2
    Seems to be that apache makes mysite.com/manual a alias to the apache manual, yet it does not explain how you turn off this "feature".

    oh i rewrote by base .htaccess file so i only need 1 now.
    Code:
    DirectoryIndex public/index.php
    Options +FollowSymLinks
    
    RewriteEngine On
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteBase /public
    RewriteRule (.*) index.php?rt=$1 [L]
    
     
  3. macrumors 6502

    Joined:
    Sep 24, 2009
    Location:
    Michigan
    #3
    It is a setting in apache.conf -- open it up a text editor and search for "alias" and then remove or "comment out" the line that creates the alias link. Sorry, I am too lazy to open mine and find the exact line. :rolleyes:
     

Share This Page