managedObjectModel relationship question(core data)

Discussion in 'Mac Programming' started by dj.mooky, Jul 1, 2009.

  1. macrumors newbie

    Feb 26, 2008
    So... I am using bindings, that I learned from reading/watching tutorials for an older version of IB. I know I am the one screwing up on this one I just do not know where, or what to do.

    I've got two entities basically
    Player and Hand

    There's a too many to too many relationship going on here, with appropriate restrictions

    I have two tables set up, one with names of all Players, and the other is currently just a list of every number associated with a hand

    How is it I make my (hand)second table ONLY show data associated via relationship to a player?

    EG: I click on me(dj.mooky) I am not interested in viewing a Hand that does is not associated to the selected Player.

    I've got it all set up in bindings like I said

    This will be just tremendously helpful once I get the real statistical engine of my app going where I'll suddenly have 5-6 entities instead of just the two during the alpha proof of concept phase.

    Current setup is table 1 is bound to Player showing value userName

    I know table 2 is setup wrong, but it is bound to Hand showing value handNumber

    Thanks in advance
  2. macrumors 68000


    Dec 9, 2001
    State of Denial
    Bind it to Player.selection.hands.handNumber. And by "it", I'm pretty sure (but not 100% sure) that I mean the NSTableColumn, not the table itself.
  3. thread starter macrumors newbie

    Feb 26, 2008
    Thanks for the answer, unfortunately your insight has only illuminated my even further screw up in writing the classes associated with my entities :)

    This is good though... learning to spot my mistakes, and finding out what they are is an amazing thing

    When I attempt doing it as you suggested, it gives me a KVC error

    I'm currently doing a search to figure out exactly what my error is, I've seen it online, I just did not know how vital it was at the time. I'll post a link in here when I find it incase anyone else ever has this problem.
  4. thread starter macrumors newbie

    Feb 26, 2008

Share This Page