Mavericks Mail.app + Gmail changes

Discussion in 'OS X Mavericks (10.9)' started by robots3humans0, Jun 12, 2013.

  1. macrumors 6502

    Joined:
    Sep 22, 2009
    Location:
    London, Ontario
    #1
    The archive button actually moves mail from the inbox to All Mail rather than creating it's own Archive label. It took me quite a long time this morning to figure out what was going on with my mail and where it was moving to. In previous versions, hitting the Archive button in Mail would create a new label called Archive to move mail into, making the user have to drag mail into the All Mail folder from the inbox in order to archive it. Now, the All Mail folder serves (as it should) as the Mail app's archive folder. Finally.
     
  2. macrumors member

    MLMcMillion

    Joined:
    Oct 8, 2012
    Location:
    Arkansas, USA
    #2
    Thank god.
     
  3. macrumors 6502

    Lolito

    Joined:
    Mar 20, 2013
    Location:
    here
    #3
    Sparrow app rocks!! apple mail doesn't.
     
  4. macrumors regular

    Joined:
    May 31, 2012
    #4
    Mine doesn't seem to do this. When I choose archive, my mail is sent to the trash in both the Mail.app and on the Gmail website.

    Actually, when I move mail from my inbox to "All Mail" manually, the same thing happens. This occurs on both my iMac and my Macbook Air (both from 2011).

    Additionally, in Preferences under Mailbox Behaviors, the "Trash" options are both grayed out. Under advanced options, there are no longer options to not keep local copies of all emails; the only two options download all messages.

    I've tried deleting and re-setting up my account as new, however, these problems still persists.
     
  5. robots3humans0, Jun 14, 2013
    Last edited: Jun 14, 2013

    thread starter macrumors 6502

    Joined:
    Sep 22, 2009
    Location:
    London, Ontario
    #5
    Make sure that on the actual Gmail website under settings > forwarding and POP/IMAP that auto-expunge is set to on (which will also set the other IMAP option to default).

    Edit: Just as I say that, I attempt to archive a message and Mail moves it somewhere other than All Mail and now it can't be found. Well.. back to AirMail for me. The latest beta fixes Mavericks incompatibilities.
     
  6. macrumors regular

    Joined:
    May 31, 2012
    #6
    Drat-- Yea, when I "Archive" it goes straight to the trash on both my mac on on the browser client.
     
  7. macrumors demi-god

    Shrink

    Joined:
    Feb 26, 2011
    Location:
    New England, USA
    #7
    Good to see that well reasoned, carefully explicated argument is not dead.:D
     
  8. thread starter macrumors 6502

    Joined:
    Sep 22, 2009
    Location:
    London, Ontario
    #8
    Yeah, I'm not too sure why it worked for a few days there and then stopped. Odd. I recommend AirMail though - the betas are rock solid (and free!) and the main app is only $1.99. The latest betas work on 10.9 so no issues there.

    The site: http://airmailapp.info
     
  9. macrumors regular

    Joined:
    May 31, 2012
    #9
    Just an FYI, everything seems to work okay now with Beta 2. The options I mentioned above seem to stay checked no matter what I do, however, the menus in Mail sync perfectly with the corresponding ones in Gmail.

    If I save a draft, it gets saved in Gmail. If I then send it in Gmail, it disappears from my Mac. Archive works, as does star tags. I think they fixed it :)
     
  10. macrumors newbie

    Joined:
    Aug 17, 2011
    #10
    Workaround with Mavericks GM

    I'm using the Mavericks GM and have found a workaround to get the desired behavior with Gmail.

    Right-click the toolbar in Apple Mail and select "Customize Toolbar...". Then drag the "Archive" button to your toolbar. If you want, you can then remove the "Delete" button from the toolbar, but I left mine because I use other accounts beside Gmail.
     
  11. macrumors 68020

    Joined:
    Mar 31, 2010
    #11
    I don't think getting an "Archive" button is the problem. You could do that in Mail with Mountain Lion. The question is after you click the Archive button, does the Gmail message go to the "All Mail" label PLUS get removed from the Inbox? Because that is the way gmail is supposed to work.

    And gmail will always be a little awkward to use in Mail.app until this is fixed. It's not really Apple's fault though. Gmail is using a proprietary, nonstandard implementation of IMAP which is causing all the problems and the reason I switched away from it.

    So have you tried Mavericks and does it now work the way it is supposed to as I outlined above?
     
  12. macrumors newbie

    Joined:
    Oct 9, 2012
    #12
    Adding an Archive button in the toolbar worked for me. And I can confirm that mails do go to All Mail and the Inbox label is removed.

    BUT I have a problem when I use my iPhone to read my mails and archive it. Mail.app on the Mac doesn't sync well with gmail : mails stay in the inbox and I have to use the archive button again so they are moved to All Mail on the mac too.

    BTW, only the mac is not up to date when i use my iPhone. The Gmail website is fine.
     
  13. macrumors regular

    Joined:
    Feb 11, 2008
    #13
    Something odd for me is that my iPhone or the Mail.App seems to be moving some emails to Archive - "Mail Account" (All Mail). This is keeping rules that run based on account from running for me.

    Not sure why ...

    (I don't purposely archive or delete anything, FWIW).
     
  14. macrumors 65816

    Ledgem

    Joined:
    Jan 18, 2008
    Location:
    Northeast USA
    #14
    I just upgraded to Mavericks last night and noted the same behavior. Is there a solution to this? It's as if many of my new emails are being shuffled into the archive before I can even read them.
     
  15. macrumors P6

    Weaselboy

    Joined:
    Jan 23, 2005
    #15
    Do you have the settings at Gmail.com set so that the All Mail folder shows in IMAP? You need to have this showing in Mavs Mail now as Mail changed the way it works form Gmail IMAP. Give this a read.
     
  16. macrumors 65816

    Ledgem

    Joined:
    Jan 18, 2008
    Location:
    Northeast USA
    #16
    Thanks for the reply. I had read over that website before replying and was interested in that suggestion; I checked my Gmail accounts and it is on (which is the default; I never adjusted it).

    It's not totally clear to me what's going on. It occasionally seems to work properly, but other times, it doesn't. I don't have enough observations to say for certain what it is, but here's another potential guess. I had a "smart mailbox" set up that would only display what was unread (conditions: message is unread, and message is in mailbox "inbox"). Normally my view was parked on that smart mailbox, but it seemed to be having a lot of problems. I've been keeping my view on the regular "Inbox" and things seem to be operating smoothly now, although I haven't received many emails this afternoon (and I'm not up to spamming myself just to test - not desperate enough for that, yet :) ).
     
  17. macrumors P6

    Weaselboy

    Joined:
    Jan 23, 2005
    #17
    I bet the way they are using those XML tags to move messages around now for Gmail is wreaking havoc with your smart mailbox.
     
  18. macrumors 65816

    Ledgem

    Joined:
    Jan 18, 2008
    Location:
    Northeast USA
    #18
    Very likely. My problem wasn't just with the smart mailbox, though, as it seems like mail was actually getting moved around. I was actually getting two notifications per email address - one would indicate that the message had arrived, and then a second would appear indicating that it had arrived - but would say that it was in the "archive" (which I was previously not using, and which didn't exist in my Mail pre-OS X 10.9). Being in the Archive instead of the Inbox is probably what was messing up the smart mailbox.

    The big puzzle relates to what I wrote in my previous post: that keeping the view on the Inbox view seems to be keeping messages there. They appear there, and I only get one notification. I don't know if Apple is shuffling them from the Inbox to the Archive and then back, or... something else.

    I'll keep an eye on it, and if I can pin it down to anything in particular I'll report back.
     
  19. macrumors newbie

    Joined:
    Jun 16, 2009
    Location:
    Germany
    #19
    I'd rather keep the old behavior. "All Mail" is just too much, I want my sent mail separate from my archived received mail. Couldn't figure out how to do that with Mavericks. Also I am missing the option to disable "Keep copies of messages for offline viewing". Is there a way to set that?
     
  20. macrumors 65816

    zub3qin

    Joined:
    Apr 10, 2007
    #20
    To all having problems with GMAIL / Mavericks compatibility, rather than complain here, let's send a complaint to APPLE


    http://www.apple.com/feedback
     
  21. Ledgem, Oct 24, 2013
    Last edited: Oct 24, 2013

    macrumors 65816

    Ledgem

    Joined:
    Jan 18, 2008
    Location:
    Northeast USA
    #21
    I can't explain why, but the behavior seems to be working as expected now. Even my Smart Mailbox is working properly, and new emails aren't being shunted to the Archive first. I haven't made any adjustments. Since Apple doesn't do background updates (or I should say, I have that feature disabled), my only guess is that Google might have changed something on their end.

    This pretty much resolves my issue.

    I also thought that I had lost the ability to see my spam folders, but I see that Apple has simply shuffled their location in Mail. Instead of appearing as IMAP folders underneath their respective accounts, they now show up in "Junk."

    Edit: Mail also appears to be a bit weird at times, as the message counts don't always match up and respond to your actions. For example, I received 50 messages, some of which were grouped in conversations. I quickly deleted messages until I had about ten left; Mail kept up at first, but then began to go out of synch with me. For a while it indicated that I had somewhere between 20-30 unread messages, even though I was down to less than ten messages. After about a minute the counts continued to adjust until they represented what I was seeing.

    The "activity" pane of Mail was blank during this process, but it seems as if Mail's counts were derived from Google's servers rather than what was in the program itself. That's the only possible explanation that I can think of to explain the delays. I'm using a SSD and wasn't straining it, so unless Mail's new database techniques are incredibly inefficient, synchronizing with an internet server (over my crummy DSL connection) seems more likely.
     
  22. macrumors P6

    Weaselboy

    Joined:
    Jan 23, 2005
    #22
    In that article we were discussing the author mentioned his system took a day for Mail to reindex all those Gmail messages before this started working properly. I wonder if that is what happened with yours.
     
  23. macrumors 65816

    Ledgem

    Joined:
    Jan 18, 2008
    Location:
    Northeast USA
    #23
    It's quite possible. I didn't notice an unusual amount of CPU, RAM, or disk utilization, so I assumed that the reindexing had finished during the first few hours of Mavericks usage (when the entire system was slightly sluggish in certain aspects, and when background resource utilization was fairly heavy).

    It's a relief to have it working properly, though. I was afraid I'd be stuck doing email from my iPad until 10.9.1!
     
  24. macrumors 68020

    Joined:
    Jan 7, 2003
    Location:
    Washington, DC
    #24
    Before I upgrade to Mavericks, I'm hoping someone can help me.

    Like many, I have gmail configured to hide all mail in IMAP, stemming from pre-Leopard days. It works well, and I have no desire to archive emails - they're in the inbox, a folder or folders, or go to the trash for deletion. Happy with that approach.

    In trying to understand the Mavericks issue, it appears to me that Mail in Mountain Lion already had addressed the funky IMAP style of gmail and had provided options to get your Mail app to act a lot like online gmail - i.e., trash meant trash, archive meant archive (not inbox, but retained in all mail).

    Is that correct? If it is correct, other than bugginess, how is Mavericks different other than it no longer works with all mail hidden?

    Or am I wrong?

    If so, is there a way to configure things to get the behavior I've described above? Nothing against how others use it, but I have no use for a catch-all archive. Either I save it in a folder or inbox or delete it.
     
  25. macrumors P6

    Weaselboy

    Joined:
    Jan 23, 2005
    #25
    From what that article I linked says, you are going to need to turn on All Mail for Mavs Mail to work properly.
     

Share This Page