Mayday: Site having trouble serving Mac users

Discussion in 'Mac OS X Server, Xserve, and Networking' started by docadams, Jul 7, 2008.

  1. macrumors newbie

    Joined:
    Jul 7, 2008
    #1
    I really need an epiphany here. I've googled everything I can think of to find a solution to this problem, and thus far... donuts.

    My website, Sarcasticgamer.com, has some serious issues when visited by the majority of Mac users.

    On their initial visit, mac users are greeted with what seems like an eternal "Waiting for SarcasticGamer.com" no matter which browser they use. It can take 3-5 MINUTES! to load that first page. AFTER THAT... no problems... site performs fine.

    Users can workaraound this issue by hitting the reload button like they're playing Galaga... Usually brings it up around click 20 or so.

    Traceroutes are not showing any issues FINDING the site.

    PC USERS do not experience this issue.

    I am RACKING MY BRAIN, SCOURING GOOGLE, and calling my hosting provider all kinds of names under my breath trying to find a solution.

    Bounty: If you are the first person to identify a solution that solves this problem, I will send you a free T-shirt from our store and $25.00 via paypal.

    MAC GURUS: Please help.

    Thank you...

    Doc Adams
    SarcasticGamer.com
    doc@sarcasticgamer.com
     
  2. macrumors G4

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    Is your server running IIS? If it is, by default IIS skips parts of TCP/IP protocol when communicating - IE understands this behavior but no other browser does. Mac users would never be using IE for Windows, and thus would encounter this problem constantly, as would Windows users using Firefox. The only solution is to turn off this behavior at the server.
     
  3. macrumors 68030

    Les Kern

    Joined:
    Apr 26, 2002
    Location:
    Alabama
    #3
    The only errors I see are that the property "text-color" declaration is dropped and use of "getboxObjectFor() is deprecated. (says try to use "getBoundingClientRect()" if possible. Seems unreasonable to assume these errors would cause THAT much damage!
    That's in Firefox 3.
    Safari loads instantly (!), version 3.x, Leopard 10.5.4.
    Attached is a pic from Dreamweaver showing problems with some of the source.
    Wish I knew more to help.
     

    Attached Files:

Share This Page