1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

MBA 13" 2010 not starting up

Discussion in 'MacBook Air' started by dpo, Feb 29, 2012.

  1. dpo
    macrumors member

    #1
    As per title.

    Have tried a few things like an SMC reset (magsafe connector light goes briefly green, then back to amber).

    PRAM reset not applicable because there is no response, no chime, nothing.

    Have also tried an alternative Magsafe adaptor which is working fine for my MBP, no difference.

    Any suggestions, apart from taking it in to have a look? Unfortunately my Applecare has also expired. :mad:
     
  2. dpo
    macrumors member

    #3
    Thanks for the reply.

    I have indeed. Nothing.
     
  3. macrumors demi-god

    GGJstudios

    #4
    Press and hold the power button for 15-20 seconds to make sure it's off.
    Plug in your MagSafe adapter and leave it plugged in for 10-15 minutes.
    Now try powering your MBA on.
     
  4. dpo
    macrumors member

    #5
    Yes, and a number of variants, and everything mentioned in the pages cited above.

    It seems to have given in.
     
  5. macrumors 6502

    prvt.donut

    #6
    Call applecare and pony up the cash for the repair...

    I'm assuming that you didn't extend the warranty...
     
  6. dpo
    macrumors member

    #7
    I spoke to an Apple service provider (no Apple store in the area) and they said that given that I have a green power light on my Magsafe adapter but it's not turning on, it could be a faulty magsafe part (rather than an entire logic board failure).
     

Share This Page