1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

MBA can't see wifi network but iPhone can?

Discussion in 'MacBook Air' started by philstone, May 12, 2010.

  1. macrumors 6502

    #1
    I've got a bit of a strange problem with my RevA - there is a network at work which is protected by WEP, I have the key and my iPhone connects perfectly, however my MBA can't even see it, it can see other networks fine and even if i try to add it manually still not joy...

    This has been ongoing for a few weeks now and still no change - anyone got any ideas?

    Cheers
     
  2. macrumors 65816

    Insulin Junkie

    #2
    A bit of reading around the net tells me it's a heard-of issue that macs can't connect using WEP, there were numerous suggested solutions, but none did the trick, it seems. (Take disabling WEP...)

    Commonly suggested solution is typing a $ before entering the WEP key. So give that a shot, if you haven't already?
     
  3. macrumors 6502

    #3
    Hi, did see that but that is working on the assumption that the MBA can see the network - mine can't even see it!

    Cheers
     
  4. macrumors regular

    Huubster

    #4
    Can you see it when closer to the router? MBA reception is not amongst the best. My Nokia N900 picks up WiFi where the MBA doesn't...
     
  5. macrumors 6502

    #5
    Nope, no difference...
     
  6. macrumors regular

    Huubster

    #6
    Does it pick up otehr WiFi networks or non at all?

    btw, nice car!
     
  7. macrumors 6502

    #7
    Yep other networks are fine, no problem at all - just this one...

    Thanks - should be upgrading to the M Coupe soon :D
     
  8. macrumors regular

    Huubster

    #8
    Try a tool called iStumbler, and see if that registers the network. If it doesn't see that WiFi network it can be both an Apple hardware or an OS X glitch
    If you have any other Macbook at hand. Try that as well. If that doesn't work with that it is most certainly os/software glitch, and I don't think you can get it to work without a bugfix from Apple!



    Wait for the new version, maybe they announce it as "just one more thing" at the WWBMWDC or any Tuesday from now :D
     
  9. macrumors 6502

    #9
    iStumbler can't see it...

    No other Macs around... Oh well.
    :mad:
     
  10. macrumors 6502

    #10
    Has this machine ever worked with this network? If so, have you tried deleting it from your known wireless networks? Do you see any errors in /var/log/system.log regarding en0? If you have a lot of known networks, you might also look at deleting ones that you don't regular visit.

    My brother had a problem with wireless once that turned out to be a permissions issue which was solved using the fix permissions under disk utility. It could also just be some oddball incompatibility with the access point and OSX. In addition to WEP, does that AP have a MAC Address filter on it? Maybe your iPhone had been previously added. Usually, in that case, you can see it, but you can't associate with it.

    You could go for the "Hail Mary" and reset the PRAM and/or SMC.
     
  11. macrumors 6502

    #11
    Hi,

    I've never connected to this network on my laptop...
    Checked the logs nothing in there about en0.
    Only have 3 networks saved -home, my brothers and my parents... all very different SSID's.

    Just about to try disk permissions...

    Will give PRAM a shot but not hopeful as I can see a free wifi from my desk (although can't connect - suspect it may be on IP lockdown)

    Thanks for the help!
     
  12. macrumors regular

    Huubster

    #12
    I really begin to think that a bug in OS X is causing this. There must be something with that network which OS X doesn't cope with.
     
  13. macrumors regular

    #13
    About This Mac

    When you open the above and click on AirPort does it "see" it?
     
  14. macrumors 6502

    #14
    Nope...
     
  15. macrumors 65816

    #15
    Did you get this sorted in the end? Iam having the same problem :(
     
  16. macrumors 6502

    #16
    Hey, no never got it to work and gave up on it - it was just the one router in my office which is a Cisco, (not Linksys, but proper Cisco) and apparently is extremely locked down...
     
  17. macrumors newbie

    #17
    Could be a wifi channel issue

    Hey,

    I had the exact same problem, I could solve it.
    I have a "Trendnet" router and it could not be seen by my MacbookAir.
    My iphone and ipad were just working fine with that network.

    I've been through the router administration console and I've tried to change a parameter: wifi channel. On that router it was set up at channel 13. Changed that to auto, restarted and it worked!

    Hope it's gonna help.
     
  18. macrumors newbie

    #18
    Macbook Prp OS 10.8.2

    I am having the same problem.
    My iphone 4s can see and connect to the hidden networks but not my Macbook Pro.
    I tried typing the name of the network and password but still didn't work!
    Please help! :confused:

    (Since it is a company network I cannot change the modem password type. :( )
     
  19. macrumors 68000

    nick_elt

    #19
    Hey not sure if you fixed it but I had this problem and all I did was change the router channel from auto to 11 or something. Give that a go, its quite a common problem I think. It must be software related.
     
  20. macrumors 6502

    #20
    How you guys change the router channel ? I have the same problem when I go home during the holidays.
     
  21. macrumors 68000

    nick_elt

    #21
    you need to access your router, each router is different I think, just look on the internet the brand of your router it should be like 192.168.1.1 or something similar in your address bar. it will pprob ask you for a user name and password which again look up for your brand of router but admin and admin are common. then you can access all your settings and etc. Any issues just reply with more details and ill try and help.
     
  22. macrumors 6502

    #22
    hey thanks :)
     

Share This Page