MBA Internet randomly shuts off

Discussion in 'MacBook Air' started by Vdubber, Apr 19, 2013.

  1. macrumors newbie

    Joined:
    Apr 19, 2013
    #1
    Hi guys

    I have tried to research this already and found no answer and so I decided to make an account and just ask myself.

    I have a 4 month old 2012 MBA 11" and I have started to notice a few days ago that my web browser would be slow to load the web pages or half the times it would not even load and says "Page could not be displayed" and I look at the wifi status bar and shows FULL BARS. I know there is nothing wrong with the internet because there are 4 laptops in this house and iPhones and iPads and they connect no problem except for mine.

    I have tried all the troubleshooting problems such as "Renew DHCP Lease" method, taking off my wifi off the Preferred list, restarting laptop, shutting down laptop, creating another account and logging in to see if the web browser would work. All those do not work.

    Its weird because sometimes the internet would work (by me not doing anything) and then all of a sudden it would stop.

    Although at the times when it does not work, I look down at the bar and see that my transmission is still downloading files, at a slower speed though.

    Does anyone know what is going on with this expensive laptop??

    it kills me seeing that my iPhone connects to wifi and loads faster web pages than my MBA
     
  2. macrumors 601

    Joined:
    Aug 27, 2012
    #2
    The obvious dumb question am going to ask is whether you are far from the WIFI router and whether same problem if u are under another hotspot.
     
  3. thread starter macrumors newbie

    Joined:
    Apr 19, 2013
    #3
    No, I'm not far away from my router, I'm only about 15-20 feet on the same floor.

    Yesterday I have read somewhere that MBAs also have a problem with connecting to wifi another another floor.
     
  4. macrumors newbie

    Joined:
    Oct 3, 2012
    #4
    Try managing the MTU size

    We have done this with several machines, and it does seem to make a difference.

    Under the Networking panel in System Preferences, click on "Advanced" and then the "Hardware" tab. Change "Configure" to "Manually" and set the MTU to 1452.

    The person who told me this trick made sense when he told me why it works, but I'm not sure I can relay the info correctly.
     
  5. macrumors 601

    Joined:
    Aug 27, 2012
    #5

    Because ethernet packet size is default 1500 byte, and WIFI "eventually" goes into an ethernet connection, sometimes, like some old DSL "add" some overhead to the the packet resulting in a MTU > 1500, this forces the router to do extra work disassembling and re-assembling the packet = slow down, but *should* never be bad enough to cause no connection. But try it out, it won't hurt, can always put it back like b4r.

    Coincidentally, ping latency from my Mac is usually higher than from my PC, but it doesn't bother me enough to spend any time on the matter, yet.
     
  6. macrumors 603

    justperry

    #6
    You seem to know your way around, so I have a question.

    I just changed my setting on my TP-Link router which has a 3G dongle attached to it, it was set to 1480, I changed it to 1452 and it seems like it is (much) snappier now, now, my Mac is connected to it by WIFI, do I also need to change the MTU there?
     
  7. macrumors 65816

    Joined:
    Jan 3, 2011
    #7
    Try changing your wireless router channel on your router. See If that makes a difference.
     
  8. macrumors 601

    Joined:
    Aug 27, 2012
    #8

    Technically once you have it set on the router, then everything connected to it should be able to auto-negotiate. Currently I don't have anything to suggest as to how to verify this is working. Most lazy people including myself also manually set it on the laptop just to be safe.

    To verify whether your manually set MTU is what is suppose to be, open Terminal Console and go: PING -D -s 1480 yahoo.com.

    If it comes back and say MESSAGE TOO LONG, then reduce your MTU until it no longer says that. The optimum MTU for my ISP is 1472. YMMV.
     
  9. justperry, Apr 20, 2013
    Last edited: Apr 20, 2013

    macrumors 603

    justperry

    #9
    Thanks, I will try the commands you gave me.

    I got exactly the same MTU 1472, anything higher got the message is too long output.

    Cheers Perry.
     

Share This Page