MBA Rev C and AirPort

Discussion in 'MacBook Air' started by CMH1085, Dec 12, 2009.

  1. macrumors newbie

    Joined:
    Dec 8, 2009
    #1
    I just purchased the MBA Rev C 2.13 SSD and am loving it so far.

    However, I notice that the WiFi connection seems to time out too often not to be bothersome and I am curious whether the MBA is defective.

    I tested the connection using my wife's MacBook and it appears that the MBA is indeed having trouble holding the connection. I got the recent updated AirPort software and do not see any improvement.

    Should I bring this in the Apple Store? Is there anything they can do? Is this a problem with all MBA's (as some others have mentioned) or could it be a defective MBA?

    Thanks
     
  2. macrumors 604

    iBookG4user

    Joined:
    Jun 27, 2006
    Location:
    Seattle, WA
    #2
    How often does the MacBook Air drop the internet connection? I have a Rev C 1.86GHz and it has never dropped a connection from my Airport Express.
     
  3. thread starter macrumors newbie

    Joined:
    Dec 8, 2009
    #3
    Hard to tell

    It happens every now and then. At least every session once or twice (during a 30 minute session I would say).
     
  4. macrumors member

    Joined:
    Oct 8, 2006
    #4
    I've only had my Rev C for a month now but I can recall zero dropouts.
     
  5. macrumors 604

    iBookG4user

    Joined:
    Jun 27, 2006
    Location:
    Seattle, WA
    #5
    That is certainly abnormal. If you're still within the 14 day after purchase period, you could go into an Apple Store and ask for a replacement on the spot.
     
  6. macrumors 6502a

    Joined:
    Nov 10, 2008
    Location:
    Denver
    #6
    How many wireless networks are in your area? What type of wireless router are you connecting to? And are you using 802.11 B, G, or N?

    I've had similar issues when in an area with a lot of other wireless networks around. Switching to a MIMO type router helped a lot and then when I finally went to an Airport Extreme, such problems pretty much went away.

    I'd say if you can't attribute it to interference from other networks or devices, you may have a problem (could be as simple as an issue with the internal antenna). My RevC has yet to loose a network connection and my other Macs rarely loose connection as well (perhaps once a month).
     
  7. thread starter macrumors newbie

    Joined:
    Dec 8, 2009
    #7
    Had it Replaced

    I went to the NYC Apple Store and they couldn't have been nicer. Aside from a small wait (<20 minutes), the service was great. They confirmed that the Airport Antenna was malfunctioning and replaced the machine, no questions asked.

    Working great now.

    CMH
     
  8. macrumors 601

    Scottsdale

    Joined:
    Sep 19, 2008
    Location:
    U.S.A.
    #8
    I have never dropped a connection with my AirPort Extreme Base Station and my MBA rev 2,1 (C) 2.13 GHz. I never dropped one with my rev 2,1 (B) 1.86 GHz MBA. I have never dropped one with my rev 1,1 (A) 1.6 GHz MBA.

    I would guess there's either a problem with the hardware or there's something interfering with the wireless connection/signal.
     
  9. macrumors 6502

    Joined:
    Mar 22, 2009
    Location:
    Rockville (Despite REM's plea.)
    #9
    I am glad to hear that this has been resolved to your satisfaction. I have to say that my Rev B has had pretty good luck both with our AEBS as well as our older Linksys WRTG54S.
     

Share This Page