MBP shuts down when the cable is diconected!!!!

Discussion in 'Mac Basics and Help' started by -Escher-, Jun 16, 2006.

  1. -Escher- macrumors member

    Dec 28, 2005
    Usually I have my MPB connected to the power cable and everything works fine...

    BUT when the cable is disconected, the computer shuts down sudenly after 5-10 minutes of use even with the full batery...I've tried to change battery saving settings but didn't work........

    ANY CLUE????????

  2. janey macrumors 603


    Dec 20, 2002
    sunny los angeles
    Try trashing the file in /Library/Preferences/SystemConfiguration called com.apple.PowerManagement.plist
  3. WildCowboy Administrator/Editor


    Staff Member

    Jan 20, 2005
    After this happens, how does the battery level read using the LEDs on the battery? And does the battery level read a good amount if you plug the machine in and start it back up?

    Just trying to see whether it's just a bad battery or something else...
  4. -Escher- thread starter macrumors member

    Dec 28, 2005
    Actually, the battery LEDs are completely off...all of them....Even with the power cable conected....But when I press the buttom on the battery by the LEDs, ALL of them turn on (either with or without the cable conected)....So it seems that the battery is ok right??
  5. -Escher- thread starter macrumors member

    Dec 28, 2005
    Just did (+restart)....didn't work....
  6. FongMan macrumors regular


    Feb 4, 2006
    i had the exact same problem. When the cable isn't plugged in it would shut down at random times. i took it to an apple store and they replaced it for free and now it's working fine :)

Share This Page