MDP to HDMI no audio!

Discussion in 'MacBook Pro' started by PNayo92, Jul 21, 2011.

  1. macrumors member

    Joined:
    Jan 1, 2011
    #1
    I have a 32" Insignia TV (from about 3-4 years ago) and an early 2011 MBP that I have recently bought. I purchased a MDP to HDMI (with audio support) to connect my computer to my television.

    This is the cable I bought:
    http://store.apple.com/us/product/H4637ZM/A?mco=MTY3ODQ5OTY

    I was able to configure my television to HDMI. However, only video streams through my television. Right now I am using Mirror mode to display my computer on the external screen. I have already gone into sound settings and changed the output to HDMI, but to no avail. It also says that "the selected device has no output controls."

    Does anybody have any advice for me? I'd really like this to work :/
     
  2. thread starter macrumors member

    Joined:
    Jan 1, 2011
    #2
    anybody? I still can't find any solution :/
     
  3. macrumors newbie

    Joined:
    Jul 29, 2008
    #3
    I had a similar situation but with a totally different set of cables (MDP to HDMI and MDP to HDMI adapter). At first I wasn't getting any sound to playback, but after a reboot everything got sync'd up and working again.

    Are you playing back AC-3 or DTS video and you're TV can't handle it? Try playing a video from youtube or something.
     
  4. macrumors 6502

    kfergiez

    Joined:
    Jul 5, 2010
    #4
    A 3-4 year old HDMI input might be the problem.
     
  5. thread starter macrumors member

    Joined:
    Jan 1, 2011
    #5
    nope, no luck with youtube videos. I don't think it's the type of audio that is the problem
     
  6. thread starter macrumors member

    Joined:
    Jan 1, 2011
    #6
    bump
     
  7. macrumors 6502

    Joined:
    Sep 9, 2009
    Location:
    Plano, TX
    #7
    Did you look at your audio settings? When I first hooked mine up, I had to change the audio output to HDMI. Worked for me. Lemme know if it works for you.
     
  8. thread starter macrumors member

    Joined:
    Jan 1, 2011
    #8
    These are my only audio setting on my TV:

    -MTS: Stereo, SAP, or Mono
    -SPDIF Type: Off, PCM, or Doby Digital
    -Audio Language: English, French, Spanish
    -Speaker: On, Off
    -Audio Out: Fixed, Variable

    I tried Right Clicking HDMI under the audio midi settings, and I was given the choice to configure speakers. Seems to not really do anything though.
     

Share This Page